BUG: Editing a Copied-and-Pasted action in RM breaks it

I just updated to .119 and decided to try the new "Copy Action" feature in RM5. I noticed a problem after pasting the copied action, while attempting to edit it. Namely, when I changed which variable a particular "Variable Math" action should apply to (fron on_UC to on_UR) I saw:

And I essentially had to rebuild the entire action from scratch. Everything else about the action got lost – the operation, the constant, the operator, etc. – as you see in the screenshot. What sucks more is I've got 8 of these to mend now. Would have gone faster by not using the Copy/Paste feature, lol!

NOTES:
• All local variables involved are of the same type (Decimal), thus are interchangeable.

It gets worse. Wanting to see if other types of actions broke when copied and pasted, I selected a 3-line IF-THEN-ENDIF block (in red box) and pasted it (shown in green).


Note from the screenshot that the comparison section of the IF statement disappeared. Instead of (Variable on_UL >= 0.5), it's now empty.

And, uh, it gets even worser... the resulting IF cannot be edited, only deleted and remade! That is, clicking "Edit IF Expression THEN" at this point presents nothing helpful (i.e. no way to substitute something else into the conditional section).

Please post the original rule so I can reproduce.

Did you save the rule after copying before reopening it to edit or edit as soon as you pasted?

I never SAVE'd the Rule or any kind of "Update Rule" prior to going on with my Edits. I will state here whether either one had any ameliorative effect...

Answer #1: Clicked "Done with Actions" then "Update Rule" ... problem persists.

Answer #2: Clicked "Done" to exit rule, then went back in ... problem persists.

@bravenel I have emailed you the JSON file for this rule.

I loaded up the rule, deleted the broken copy of the IF-THEN actions (3 actions), then copied the original 3 from just above where it was, and pasted those. Worked perfectly, no broken action, no missing conditions. So, no explanation possible for what you found based on that...

And, also there was no problem editing that Conditional Action. There isn't must to edit, just a single condition. Could also edit the condition with no problem.

1 Like

Roger that. Will keep an eye, specifically on the Clipboard, during future Cut-and-Paste operations. Can also confirm no problem occurred during Copy/Paste of a different Action type, namely a Switch ► Toggle.

Sorry for the flurry of bug reports all in one day. I have a cold, therefore more time to poke!

Happy to email you JSON of this test rule, @bravenel, if requested. Note that I created it solely for the purpose of seeing if a 3-line IF-THEN could Copy and Paste correctly (it did not), and that the Rule was not yet installed when I took this screenshot.

Clicking DONE to complete the Rule and coming back to edit it, the issue of the missing conditional persists. Not sure why this won't replicate on your system. Because as you had done, I deleted lines 4-6, re-copied lines 1-3 and pasted them anew, only to see the same issue on line 4 again.

You aren't showing enough information, for example what's on the clipboard?

This works perfectly for me:

I'll widen my screen grab(s) and get back to you here, sorry.

This should cover it... let me know if I'm still missing important details...

Found a bug that causes this. Fix in next release.

2 Likes

@bravenel When I tried to copy/paste this:

I ended up with this:

image

On a C7 running 2.3.0.124 and the RM App is: Version 5.1.1 (12/28/2021)

Based on the release notes and the time of your last response--I wonder if this is a similar/related issue that may still exist.

Thanks.

Yes, it was reported and has been fixed for next release. Copy/paste of Simple Conditional actions fail.

1 Like

Download the Hubitat app