Bug: Edit expression error

@bravenel I have tried to edit an expression in 2 rules, both times when I tried the page turned to one that showed "unexpected error" - Error: No signature of method: java.lang.Integer.isInteger() is applicable for argument types: () values: [] Possible solutions: toInteger(), getInteger(java.lang.String), getInteger(java.lang.String, int), getInteger(java.lang.String, java.lang.Integer), toBigInteger()

and then thereafter it was impossible to edit the rule at all and I had to reconstruct them completely from scratch

I need to see the rule, and a screenshot of the log with the error. Also, would like to see the App Status page, Application State for the rule. If you can cause it to break again by repeating the steps that would be great. I need to be able to reproduce the error, to see what you did that caused it.

I'm experiencing the exact same thing when trying to edit expressions. Happens every time to any of my rules. Also, once I get the error I can no longer edit any of actions in that rule and just get the error screen when clicking on the select actions to run box. Here are the screenshots.

Here is anther rule with same results when trying to edit the expression:

Thanks. Do you know at what step in attempting to edit that it blew up?

Could you post the App Status page (gear icon) for one of the blown rules?

Yes, as soon as I click the "Edit expression" box

Ah, thanks. Please show me the App Status page for one that is blown up.

Nevermind, I can reproduce it. Something got broken...


Here you go:

OK, there will be a fix coming out. If you keep those rules around, they will start working after the fix is released.


This bug has been fixed in the latest release

1 Like