Broken in hub version 2.3.0.124: Advanced Honeywell T6 Pro Thermostat

if i have a global variable and write the same value over and over (like 71 to idealTemperature) would it trigger a "changed" message each time i write the same value? or would the system only send a changed message when i write a different value, thus filtering out duplicate writes?

i don't understand what's wrong with my z-wave network. i have a t6 thermostat. i have a motion detector. i have an energy meter. and a hubitat hub. how is this bad? they are all within 30 feet of each other. everything but energy meter is within 20 feet of hub. the energy meter never falls off the z-wave net so far. i have a repeater i can plug in somewhere i just don't know if / when / how it helps.

Can you post a screen shot of your z-wave details page?

2 Likes

You'll only get a changed event if the value changes...

2 Likes

0x0A, 0x0B and 0x19 appear to be failed pairings, suggest you remove those before doing anything else...

2 Likes

You mesh is a mess, you have 4 ghosts.... You need to remove them. The one aeotec repeater needs removed and readded (note no route)

2 Likes

If you're sending that value to the thermostat, it will send it each and every time.

thanks for these great tips. i have removed the ghosts now! repeater is not plugged in at the moment so i guess this should be ok or do i need to do more? i am thinking i can just see how this works for a few days and then continue on the more challenging change-based system which would of course be better (more quiescent) over z-wave

Bad idea. The radio doesn't know it isn't there. Before removing a repeating node, exclude it first.

2 Likes

Also, the large number of route changes for repeating nodes - the energy meter, for eg. is indicative that the mesh isn't healthy.

While 30 feet may not seem like much, in practice there are many things that affect z-wave radio signals, including antenna placement, building materials, and other devices (phones, some baby monitors etc).

1 Like

Plug the repeater back in...Do a z-wave repair and let things settle.

2 Likes

this is great i feel like my z-wave network is really getting stronger with all these routes. i had no idea ghosts were grouping up on me so bad before and no clue why my network seemed so overcomplicated. does it look good now?

2 Likes

The zooz 4-in-1 is your major weakness now. It's paired at S0. You need to use a z-wave stick to pair with no security. The reason is that their implementation of s0 is incredibly chatty. So chatty it can bring down meshes. I'd also re pair the thermostat with no security. The only thing you should use security for are locks and garage door stuff.

4 Likes

Your repeater entry (below) should clear up once you plug in the repeater:

If it doesn't fill in w/details like the other devices, then you can try using Refresh and then Repair and then reboot your hub after the repair completes so you're starting as fresh as possible.

3 Likes

thanks Dana. it did not clear up by itself. i tried refresh and repair and reboot but no luck. i cannot even seem to remove it. waiting a long time in the ZWave logs shows it is trying to communicate in a sense i think:

1B2022-01-11 17:22:32.120 seqNo: 130, routeChanged: false, transmissionTime: 0ms, repeaters: None, speed: Unknown, rssi: [0 dBm, 0 dBm, 0 dBm, 0 dBm, 0 dBm], Ack channel: 0, Transmit channel: 0

1B2022-01-11 17:22:32.117 seqNo: 129, routeChanged: false, transmissionTime: 0ms, repeaters: None, speed: Unknown, rssi: [0 dBm, 0 dBm, 0 dBm, 0 dBm, 0 dBm], Ack channel: 0, Transmit channel: 0

1B2022-01-11 17:22:29.907 seqNo: 127, routeChanged: false, transmissionTime: 0ms, repeaters: None, speed: Unknown, rssi: [0 dBm, 0 dBm, 0 dBm, 0 dBm, 0 dBm], Ack channel: 0, Transmit channel: 0

1B2022-01-11 17:22:29.905 seqNo: 126, routeChanged: false, transmissionTime: 0ms, repeaters: None, speed: Unknown, rssi: [0 dBm, 0 dBm, 0 dBm, 0 dBm, 0 dBm], Ack channel: 0, Transmit channel: 0

since it doesn't have a device link / entry is there something i can do to "force remove" it ? i have the manual to factory reset the repeater but i have no idea how to get it out of the z-wave details page where it always seems to be stuck half-configured (z-wave 1b node assigned but no device name/link)

Put the radio into "exclude" mode and then run an exclusion on the device. Do not force remove the device - you'll be left with a stranded node that is difficult to remove.

Here's how you exclude the Range Extender 6:

Here's how you exclude the Range Extender 7:

i've been trying that exact procedure (range extender 7) several (5 or more) times. one complication is the lack of visual feedback from the hubitat to show it's in z-wave exclusion mode. i can try the advanced alternate real time zwave logs trick i've read. but it's still not clear if it's excluding properly. i guess i need to just keep trying?

i rebooted hub and i got it to exclude. wow that was tough. i guess it has a stuck mode when you press repair or refresh or sth

i got it re-included properly finally phew
ty for help

2 Likes

For giggles to clear everything out and to make sure you're hub is healthy do the following.

1: Go to settings>>backup. Click the download button at the bottom and save to local PC (The database will be cleaned during the backup process)

2: Go to yourhubip:8081 and do a soft reset. (You will need the mac address from the bottom of your hub). Upon reboot it will ask you to restore. Restore from the backup file you made on your computer, not from the ones on the hub.

3: Now shut down hub from settings menu. Unplug at wall (not hub) for 20 mins. Power back up. (This will clear the z-wave radio)

4: Optional. Do z-wave repair.

This will ensure a squeaky clean system for you after all your troubles.

1 Like

Download the Hubitat app