Blue Light

I have a C5 hub that I decided to do a soft reset on - Since then I've had a continuous blue light on the device after reboot.

I am still able to access the Diagnostic Tool at and have tried everything in the suggestions found in this forum but nothing seems to work. I've tried reaching out to support a few days ago with no response. Finally I tried reaching out to @bobbyD yesterday directly with no response as yet.

Can someone please help with suggestions on what I can do next? It's extremely frustrating to have what appears to be a bricked hub, and reading the forums this seems to be a fairly common occurrence.


When you did the soft reset, when it came back up, did it give you the option to restore? Are you running a static or reserved ip or neither?

Also I'm sure @bobbyd or @support_team will respond soon

There is an option to restore, however the list of choices is empty. This is the popup message I see:

"You are currently running .
Select one of the following versions to switch to:"

Not running a static IP, also don't have a DHCP reservation at the current time. Would it help to have one, as mentioned I am able to access the Diagnostic Tool?


It is not common at all. It occasionally happens with new hubs that were not formatted correctly, and often the resolution is to get a replacement. It sounds like your hub encountered a critical error and likely is not recoverable.

If you have extended warranty via Hub Protect, it would be covered and you would be able to restore the cloud backup on a new hub.