[BETA] Tasmota (Connect) - Pure Tasmota/HE Integration + real-time status (for Sonoff, Tuya, SmartLife & other ESP8266 devices) - ST port

HONGTAT TAN recently created a new ST smartapp + device drivers that work with pure and unmodified Tasmota v8 devices. I modified the app and device drivers to work with Hubitat ******* it required a significant amount of work due to the limited hubitat implementation of hubitat.device.HubResponse object, the lack of a proper query parameter + plus the different arguments required in addChildDevice method ******

Previous Tasmota apps for HE required a modified firmware, something that I was never particularly fond off.

I have tested the app and devices drivers with:

  • Tuya plugs (1CH or 2CH) - using tasmota-generic-switch.groovy
  • Sonoff Basic R2 / R3 - using tasmota-generic-switch.groovy
  • Sonoff TX - using tasmota-generic-switch.groovy
  • Sonoff mini devices - using tasmota-generic-switch.groovy
  • Sonoff iFan03 - using tasmota-fan-light.groovy + tasmota-child-switch-device.groovy

Features

  • Real-time device status
  • Pure Tasmota & HE integration (No need for additional MQTT bridge)

Requirements

  • Tasmota v8 Device (with a working module / template)
  • 1 CH or 2CH switches (see limitations) (tested)
  • ifan03 or ifan02 (tested)

Working and tested device drivers

  • tasmota-generic-switch.groovy,
  • tasmota-fan-light.groovy,
  • tasmota-child-switch-device.groovy
  • other device drivers will eventually be migrate

Current Limitations

  • Devices must be added throught the smartapp
    tasmota-connect
  • After configuring the IP address, you MUST manually initialize the device from the device screen (click the initialize button) - otherwise, the device will only work on polling and not in real time
  • Due to limitations of this beta code (the escape of the URL query parameters is still quite basic) it may not work if your device name have a rare condition

Installation

Please make sure to install the SmartApp and ALL device handlers.

Original thread:

FAQ

  1. "Your idea is stupid and slow and I don't like it" - Don't use the code
  2. "Your app/driver is crashing my Hub. I submitted a support ticket" - Don't do that, the fine folks at Hubitat Inc. do NOT maintain this code. This software is given free of charge with no support, implied or otherwise. I may still help...
  3. "The latest update broke it, FIX IT" - I do this for fun, please don't make it un-fun.
  4. "I have a great idea for a feature" - Go ahead and post it, I might get around to it...
  5. "You ignored my great idea" - See #2
  6. "I hate you for getting my hopes up, your app/driver is awful/buggy/stupid" - Ok, please write a better one so I can use it
  7. "Please fix your code, it's broken" - I write this because I enjoy coding. I will continue to support and provide updates as long as that remains the case.
  8. "I stole your code and made it soooo much better" - Thanks. Please post it so I can start using it.
  9. "You are awfully sarcastic, I don't like you" - That's ok, I don't need you to
    (thank you @thomas.c.howard for the original FAQ this one was based on)

ENJOY AND REPORT YOUR PROGRESS!

2 Likes

I'm sorry, but this is the same app that your release 3 weeks ago. That one wasn't "real-time" and neither was this one. This app/driver relies on polling to the switch to get local changes made on the switch rather than a real-time status update. Calling this real-time is deceptive and misleading.

1 Like

Interesting. I’m glad you commented on this Ryan. It caught my eye because I am running 17 Teckin SP10s with @markus driver, i do have access to his new beta but I haven’t tried to update yet. The current driver is working great.

The additional (claimed) features in the subject of this post was enough click bait for me. Thanks for posting your findings.

1 Like

I am sorry. Please make sure that you tests the app and device drivers before commenting.

@pgux Is this local?

Thank you for all your work I was so worried that tasmota wouldn’t work until I came across this.

The author of this driver hasn't posted anything since May, it might be worth searching some more in the forum for an answer.

1 Like

@markus I’ll just block both my hub and smart plug and see how it goes

This is local with the Tasmota firmware, since this is in a release thread I will not discuss alternatives, again, search the forum. :wink:

@markus it works even if wan is blocked

Yes, that is not the concern, if you're happy, then use this :slight_smile:

1 Like

@Abhijeet_Ghosh another option for you are these drivers.

@jchurch I tried that... it feels a bit too cumbersome with child devices for even single plugs

That's just the nature of the "generic" drivers working their magic but the most important part is they are well supported. That said if this works for you and your happy then that's what counts :slightly_smiling_face:

@pgux there is a bug in this that any device that is not a generic 1 ch switch will not report data until polled. This does not seem to have any affect from brand. All 1ch plugs and switches work, all dimmers, 2ch plugs, and power meters have this bug. Doesn’t really matter on the specific devices I have, as you can still give the off command even if the device is off and it will work. It would be nice though if this were to work. Two of my 2ch smart plugs are inaccessible so no way to press the button, but the dimmers button is pressed. However, no automations based on if a button is pressed so I am fine. Also the power monitoring doesn’t show a power variable. Again don’t have any automations for the power so no need..just want.

@jchurch this occurs for all devices with your integration. However, the power monitoring does work, but it must be refreshed to work.

PGUX! Thanks for the coding!

Can some help out here?

I have recently acquired a HE Hub and I'm trying to connect all my Tasmota devices (mostly Minis and Basics).

I've added the "User App", but after choosing the device type and typing the name I get this message:

Have you added all the device handlers?

Please follow these steps:

  1. Sign in to your SmartThings IDE.

  2. Under 'My Device Handlers' > click 'Settings' > 'Add new repository' > enter the following

Owner: hongtat, Name: tasmota-connect, Branch: Master

  1. Under 'Update from Repo' > click 'tasmota-connect' > Select all files > Tick 'Publish' > then 'Execute Update'

Error message: Device type 'Tasmota Generic Switch' in namespace 'hongtat' not found.

Help? Please?

@gusthepenguin I got that error too. It is a namespace error. I just changed the namespace and now it works. I forked hiss repository and edited this. Here it is:

Tasmota Generic Switch cannot be found because it has been renamed to Tasmota Generic Switch Test. Renaming it back works.