[BETA] Rollease Acmeda Automate Pulse

Just published version 2020.06.08.01

This version automatically resets the Telnet connection if it doesn't detect any activity. I've been running it for a couple of weeks now and I haven't had to manually reconnect. It also adds a toggle command to the shades and some other attributes.

Thanks @Younes. That's great news. I'll install this afternoon.

Many thanks for this driver.

Cheers.

So just to confirm, this is for v2 only yes? So my original hub won't work at this stage as the open port can't be accessed... Yet

Yep, I have both Gen 1 and Gen 2 of the Pulse interface. The Gen 1 won't work with this driver. I tried using RS485 on the Gen 1 but got nowere so I got the gen 2.

Does the gen 2 operate the original blind motors? I'm assuming it's the same blinds, just a different hub?

What benefits other than faster response do you get using hubitat drivers over ifttt integration? I guess hubutat knows the state of the blinds? And a little bit faster.

@peterbrown77.pb

Yes, the blinds are much quicker (about 1 second delay after trigger)

IFTTT cost money to the company. Acmeda didn't push a new Hub for nothing, I think they will eventually phase out the Pulse 1 service.

I haven't played with the driver much but everything is in there:

Current States

  • closed : false
  • moving : false
  • open : true
  • position : 100
  • voltage : 01181
  • windowShade : open
  • lastDirection : closing

Plus SetPosition and SetLevel, Toggle, On, Off commands

Everytime I operate the blinds, my hubitat log gives me this error: java.lang.ClassCastException: null (parse)

Currently my blinds seems to be operating as it should in Hubitat using this app (thanks so much!), any idea what the error is about?

Hi @Younes. Thanks again for all your work on this intergration.

It had been running fine for the last two weeks but it appears this error cropped up following a reboot of the HE hub this morning at 4am.

Pressing "initialise" on the parent device didn't fix it this time. However a reboot of the Pulse Hub did.

Thanks once again for your help with this.

Hi @darren3220, what I noticed is that sometimes the Pulse Hub stops accepting Telnet connections, I experienced this often during driver testing when I would connect/disconnect multiple times, the hub would stop accepting connections after a while. However after a few minutes it starts accepting connections again.

In your case does the Pulse hub ever begin to accept connections again? Or is the only to get a connection is to reboot the hub?

Hi @Younes. In my case I had to reboot the Pulse Hub. I let about 4 hours go by and it still had not connected. I have the Connection Retry Interval at 300 and Maximum Idle Time Reset At 3600.

I’ve enabled debug mode to see if it picks up anything further if it happens again.

Thanks for your help with this.

Noticed it was offline this morning. Logs are below. This time hitting initialise seems to have got it working again temporarily. I’m not sure if it had something to do with it but it went offline at the same time I opened the device and enabled debug mode.

However a few minutes after hitting initialise it went offline again.

Hope this helps. Cheers.

Hello! This driver is working for me and is very snappy. Only thing I've found difficult is how to incorporate the toggle feature with a button. Trying to use Button Controllers, but the Switch toggle only opens the shade and there is no option for shade toggle.

BTW- The toggle works great within the device settings, it just doesn't seem that the Switch toggle is the same as the toggle from this driver.

Sorry guys, after spending most of last night trying to figure this out, I learned that a I needed to run a "Custom Action".
Here's a screenshot of an example.

So just to check before I go and buy the v2 hub.

This driver hasn't been successfully used for the v1 hub due to the ports not being open?

Is v2 integration quite stable now or requires a hub reboot every now and then?

Ifttt are now double dipping and looking at charging to use their service (even though I paid for it through the device) so ifttt is not ideal as the link between hubitat and my blinds now. I don't particularly want to buy a new v2 hub but I will if it's the only way to get my blinds working without paying ifttt a subscription.

It’s been running very stable for me over the last few months. No rebooting the hub necessary. I think that some of the problems I initially had can be attributed to HE hub instability rather than the integration itself. I have v2 of the pulse hub.

1 Like

Thanks that is good to know. I'd prefer to update my hub and buy v2, than pay subscriptions to ifttt. I now have a bigger reason other than small delays to justify changing the hub now.

Like Darren, I have been using this driver for a few months now and have been very smooth, no hub reboot necessary.

I integrated the blinds with my google home by creating virtual switches in HE which are linked to google home. When the virtual switch is turned on in google home, HE will close/open (or toggle) the associated blinds. I also set the virtual switches with a 2 second auto off.

This way I no longer rely on IFTTT.

Yes is how I have mine now... I have 3 states with the open, privacy and Blockout states so I created a switch for each state. But I trigger with google home - > home - > hubitat or by the virtual switches in hubitat - > iftt. So it adds a delay and now also costs seeing the amount of applets I need.

The hub is $220 but I'd prefer to pay them than paying ifttt after seeing this driver works well. The delay doesn't bother me, and the ifttt link has been reliable.. But it's a principle = stubborn

Hello! I have a v2 Pulse and was happy to find this device! I have my shades operating properly via the Automate app. I followed the installation instructions for the drivers, but it seems I am having issues connecting to the device over telnet:

dev:2382020-09-30 05:32:18.694 pm infoScanning for shades...

dev:2382020-09-30 05:31:49.092 pm infoScanning for shades...

dev:2382020-09-30 05:27:36.546 pm errorjava.net.NoRouteToHostException: No route to host (Host unreachable) on line 58 (updated)

dev:2382020-09-30 05:27:33.430 pm infoRollease Acmeda Hub Opening telnet connection to 192.168.4.77

dev:2382020-09-30 05:27:22.102 pm infoRollease Acmeda Hub Opening telnet connection to null

(Note that I modified the log message to confirm the device was connecting to the address I expected.)

I tried scanning for ports (as described in this thread) and it there do not appear to be any ports open on the Pulse device. Any suggestions?

Oh I'll keep a close eye on this. I hope for you (and my future purchase) that they haven't changed any ports with firmware or hardware updates.

Download the Hubitat app