[BETA] Rollease Acmeda Automate Pulse

Thanks @tonysosw for the suggestions. I am using a static IP and confirmed it was referenced in the Preference section.
While I had power cycled the hub a couple of times while troubleshooting, I tried again later and the issue has gone away. No issues for a couple of days now. I'll update if that chances. Thanks again!

@Younes - Thank you so much for these drivers. They are the most used action in my setup. If you have a https://www.buymeacoffee.com/ profile, do share with us :wink:

I write to find out if anyone else is hitting the following error - seems to happen about once or twice a day either during opening of all (12) shades I run in the morning or closing of all shades I do in the night. The shades on which this happens varies.

java.lang.NumberFormatException: For input string: "?,R" on line 146 (parse)

I run a similar number of shades but can't say I've come across that error. I've just turned on debug mode to see if anything pops up in the logs from that and will let you know.

Thank you, @darren3220.

I have 10 shades in my house and they are running great. Occasionally One of the shades will lose connection to the pulse hub but they always sort themselves out.

However I do have the error you quoted in my hubitat log. Like you mentioned, it doesn't happen every time and it does not seems to have any impact on the operations of the shades.

Just checked my logs after running in debug for the last 24 hours. Haven’t received that error and I can’t recall having seen that error in my logs previously. Not sure why it’s not coming up on mine.

Just checking if this is still working well for everyone? Considering upgrading my v1 hub to v2 to work locally... Thinking..

Still working fine for me.

1 Like

I'm sure I am doing something wrong.. but I can't get them to work as a group. I've created a dimmer group and added to a dashboard and just get errors.

Has anyone else got a working solution to control a group of blinds?

java.lang.IllegalArgumentException: Command 'setPosition' is not supported by device 92. on line 597 (method dashboardCmd)

Try this : Help combining three shades as one

I also had issues controlling as a group

Thank you for this code @Younes as it has worked quite well for me since 2020.. One thing that did crop up for the first time today when I added a few more new shades to my system was that when I now call 8 shades to operate at once, I am met with about a 50% success rate. Sometimes a single shade won't move in the group, sometimes only 1 shade will move and the other seven hang. If a shade doesn't work after activating, you can wait and 50% of the time the shade might trigger after about 10 seconds. I don't seem to have any issues if I'm calling for 5 or less shades moving at once. I even tried triggering the shades "serially" by putting a couple of seconds between each shade call thinking that the hub was getting overloaded with telnet calls. This did not change in reliability.

I've also seen inconsistent control capability w/ the iOS Rollease/Shadestore shade app.. For instance, if I trigger a bunch of shades to move via HE, but one stalls.. I can't manually control that non-functional shade via the Rollease/Shade Store app for a while. If I use the Rollease hardware remote, and manually control the shade it will move the shade 100% of the time at point, and literally wake up the shade in the ios app so its usable again. Not sure what this correlation is all about.

FWIW it's Shade Store branded rollease acmeda v2 hub.

thanks for any insight!

I’m running 10 shades in a single room and they all go up and down without missing a beat. I don’t use a group and just refer to each blind individually in rules. Is your Pulse Hub close to the shades? Just wondering if range between the hub and blinds could be an issue. My blinds are all within about 5 metres of the hub. Example of one of my blind rules below.

I've also seen the odd blind not go up once the quantity of blinds increased. I'm using the ifttt trigger as I have v1 automate hub. Moving the hub hasn't helped.. I find that if I send the command for all blinds up again that all go up the second time around. So it appears it's not a coverage thing, as they always go up the second time around, and perhaps a bug when they are all down and then told to all go up. Don't know if that made sense as I'm sure there's some better terms to use. Point is, if I tell them to go up twice they all always go up. Only once, they occasionally miss the odd one or two and not always the same ones. I believe it happens at the automate end, rather than a hubitat or ifttt thing.

1 Like

Thanks for responding guys. A few notes:

  • hub location/signal/interference is not an issue, I've relocated the hub within 5', and I will get ones that don't activate still.

  • @darren3220 i've read earlier posts from you, and you seemed to have a lot of similar problems that I am having, what resolved? @Younes update in the middle of 2020?
    I've adjusted the time out params to be much shorter to no avail as well

  • @darren3220 all shade movement is done via shade position calls (IE I might have 2 shades at 77%, 2 @ 75% and 2 @ 68% so they all line up exactly across all the windows). I see that in your programming it is not just full open/close calls. I do wonder if that makes a difference.

I'm giving Rollease a call tomorrow.. has anyone tried their tech support? Are they helpful?

thank you!

I just got my 6 shades in yesterday and applied this driver... works like a charm! So excited.
One question I have is, what's the difference with position and level? They both seem to do the exact same thing from my tests.

Also... is there any method anyone knows to "micro adjust" the shades via Pulse 2 hub to get "Zebra Blinds" to line up perfectly when partially opened?

Thanks in advance.

@Prometheus_Xex did you have any luck figuring out
"Also... is there any method anyone knows to "micro adjust" the shades via Pulse 2 hub to get "Zebra Blinds" to line up perfectly when partially opened?"

I too am about to install Zebra blinds.

Unfortunately haven't found out yet.

Thanks for responding @Prometheus_Xex

1 Like

Hi @Younes thank you for providing this great API integration. I was wondering when you have some time could you add the battery % attribute if it is available?

Finally updated to a pulse 2 hub (from an ageing pulse 1) after some great customer service from Rollease. So far these drivers work very well so thanks.

I'm assuming that because these are we taking locally with the hub is the reason the blind names aren't carried over? Not a problem as it didn't take long to manually name them all but just checking in case my integration isn't fully right.

Download the Hubitat app