[BETA] Echo Speaks V4

Wanted to pass along that I am still getting debug logging even though debug is disabled


1 Like

Tony has pushed an update that fixes:

  • race condition causing some commands to not execute
  • further quieting of logging
2 Likes

Regarding Docker instructions, here's my post from v3, no changes need for v4: https://community.hubitat.com/t/release-echo-speaks-v3-actions/22879/1071. Don't forget to git pull origin the next time the server needs an update! :wink:

2 Likes
5 Likes

Public version available :slight_smile:

Those already running the beta build can just update to the latest beta to always have the current code.
I will still be using the beta branch to push out new features and fixes before pushing to master.

3 Likes

HPM Issue
Originally I had installed Echo Speaks master from github and then installed HPM. (HPM has certainly made this a lot easier to keep updated)
I found HPM offered me the Echo Speaks Beta (4.0) which I installed and has worked ok.
Now with this update I find it wants to update both versions. I chose to update the 4.0 to 4.1.
I cannot update both and I cannot uninstall one as they are both called "Echo Speaks" and I selected the first one which said a file was busy.
Any ideas how to end up with just Echo Speaks 4.1.0.0?

Echo Speaks v3.6.4.4 (app)
Echo Speaks - Actions v3.6.4.2 (app)
Echo Speaks - Zones v3.6.4.1 (app)
Echo Speaks Device v3.6.4.1 (driver)
Echo Speaks WS v3.3.1.1 (driver)

Echo Speaks v4.1.0.0 (app)
Echo Speaks - Actions v4.1.0.0 (app)
Echo Speaks - Zones v4.1.0.0 (app)
Echo Speaks Device v4.1.0.0 (driver)
Echo Speaks WS v4.1.0.0 (driver)
Echo Speaks Zone Device v4.1.0.0 (driver)

In the end I have updated both, but I really do not know which one is really being used.
Echo Speaks 4.1.0.0 is the "App" in the Hubitat interface.
EchoSpeaksHPM

Perhaps my point is more obvious with an image.
maybe "Echo Speaks" and "Echo Speaks Beta" would be better labels?
EchoSpeaksHPM

I wish there was an easy way to handle this. Hopefully this won’t be an issue for much longer.

Thank you for the reply

I am trying to Update to Version 4.1.0.0 but keep getting the error message of 'Unable to save to the hub, please try again and check if the hub is responding'?

Did Amazon change something with Echos and adjusting volume. I have a very simple use of Echo Speaks. If a door contact is opened, turn volume up to 8 play a blank announcement (just want the do do tone) on 2 dots, then restore volume to 3. Earlier this week, I started getting beeps for when the volume is adjusted. Never had that before...any way to remove?

Try rebooting your hub before updating.

1 Like

Over the past 2 days, I seem to know get a beep at the end of one of my announcements, haven't checked others at this point

I think that 'beeps' were added by Amazon/Alexa. I use both NR and HE to make Alexa talk and without changing anything, I've noticed a beginning and ending 'beep' for every announcement.

My hero :muscle::+1:

I seem to remember that changing the volume used to have an auditory confirmation, but that stopped at some point making them silent. Like you I’ve noticed the confirmation tone at the new volume setting is back, and I can’t see any setting to turn it off. Very annoying.

Having an ongoing issue with an error that is filling my logs...

This device is an Echo Flex. The weirder part is I actually have logging disabled for this device...

And here's a more extensive log showing some app logging as well.

I decided to delete the device and let the app re-add it... here's what I have now, which at least looks promising.

Aaaand I think I figured out the problem. I had two copies of the echo speaks device driver, one from about a month ago and one from a few days ago. When I went to delete the old one I was told that it was still in use by the same echo device throwing up the errors. So I deleted the device, then quickly deleted the older device driver before the app recreated the device. It seems like that did the trick. Whew!

I've tried installing both versions of this that show up through HPM, but no app or device is listed after the install. There are 3 items listed under Apps Code and Drivers Code - do you have to create the app and device instances manually? What should the next steps be?

HPM loads the code into the correct locations for HE, but you still need to go to the Apps tab and Add a User Program to create a runnable instance.

@tonesto7

Started seeing this error this morning:

image

Download the Hubitat app