Arghh: only one Hubitat rule works and only 20% of the time

I am having the most painful experience trying to get Hubitat working in my new home. I have 12 Zooz dimmers, 1 Zooz motion detector, and a few smart plugs set up in the house. Here's where things stand:

  • The Zooz motion detector will capture motion and show a "Rule Machine" (Rule 5.1) Event for it in Hubitat about 10% of the time. When it does the rule triggers and the light comes on. Some days it will get up to 80%. It seems totally random when it will work and when it won't. Most of the time I can see the LED on the motion sensor flip on when I enter the room but Hubitat doesn't log anything and the light doesn't come on.

  • None of my "Basic Rules" (Basic Rule 1.0) for exterior lights turning off at sunrise, on at sunset have ever worked. Hubitat will call a command and the lights don't respond.

  • Likewise, the smart plugs receive commands to turn on and off based on my time of day rules and do not respond / nothing happens. I see "Command called: on" and "Command called: off" in the device logs but nothing actually happens. There is no log of the devices turning on or off. For these I tried using "Simple Automation Rule 1.2"

I have spent a ton of time with Zooz troubleshooting and nothing worked. It was only once I tried using Hubitat with a couple of the Jasco smartplugs and hit the same dead end that I recognized that Hubitat may be the issue.

I can go into Hubitat and manually turn on and off the lights from within the interface (is this called using the "paddles"?). So it seems like my computer is linked to Hubitat which is linked to the devices. Yet most of the rules I've created using 3 different approaches will actually turn things on and off.

Any ideas on how to resolve this?

Post the rule.

Here is the rule to turn off the exterior lights at sunrise.



Here's the rule for the motion detector / turn light on.

Can you post screen shots of your entire Z-Wave Details page? You may have some Z-Wave ghosts which are causing your problems.

4 Likes

What @danabw said and also turn on debug logging for the motion sensor and try tripping it a couple times. See if its logging activity every time or not. The reports from sensor may not even be making it to the hub if the mesh is unstable.

What hub model? Firmware?
If C7 have done the Zwave firmware update?
Are the smart plug Zwave or Zigbee? Make/Model?

I have a whole house of Zooz stuff, switches, dimmers, (5) motion sensors, (1) door sensor, etc.. all my rules fire off about 99% accurate at this point. I have one ZSE11 that is slow for motion sometimes but that's the sensor itself. Point being, its possible for it to work well.

1 Like

Here are the Zwave Details screenshots. I am continuing to have the same issue. None of the dimmer rules with two exceptions:
(1) My Zooz motion sensor will trigger the closet light though with a slight delay
(2) My rule to turn off all lights at 10:30PM will randomly set off about once a week but will do it at 8:30PM which is a time I had set when I was troubleshooting weeks ago. I changed it back to 10:30 so there is no reason for it to do it at this time.

My level of frustration with Hubitat is sky high. Had to take a few weeks off before coming back to try to deal with this.


It is likely you have three z-wave ghosts:

0x19, 0x1B, and 0x1C.

Also, can you describe the Zooz device that is 0x18 in more detail please (model, and how it's powered)?

1 Like

Thanks for the information. How do I deal with z-wave ghosts?

The 0x18 device is a Zooz motion sensor ZSE11: https://www.amazon.com/Z-Wave-ZSE11-Temperature-Humidity-Required/dp/B09GDL6BGY/

Just saw something else.

You need to update your z-wave radio firmware. Please do so immediately by pushing the Firmware Update button on the z-wave details page.

1 Like

I would say 0x19 possibly just does not have a route populated, since the name is unique.
0x1B and 0x1C look like they are maybe duplicated or if you have two of those try bringing them closer to the hub to see if the info populates.

I think overall there is just a bad situation going on here. It looks like nearly every device is routing through 0x0D. Is that Dining Chandelier dimmer very close to the hub or in a central location?

Where is the hub located and is it inside of anything (Cabinet, etc...)?
What is your home construction type (Drywall, plaster, block, etc...)?

Asking again:
What hub Firmware?
Have you done the Zwave firmware update?

This is not really possible unless you have duplicated the rule and have both copies going, or your hub clock is wrong (which could be from an incorrect time zone).

1 Like

Updating now thanks.

1 Like

Dining Chandelier is by the hub. I had previously had the hub in my office near the front door but moved it to see if putting it towards center of the house would make a difference. It didn't. It's currently sitting out on a countertop. House is drywall.

Will report back on hub firmware when the Zwave firmware update is done.

After you do the firmware update, shut down the hub via the settings menu. Unplug power to the hub (at the wall not the hub) for a few minutes then power back up. This will clear your radio. Then repost your z-wave details page.

The zwave firmware update will help a lot.

How long has it been in the new location? Might take a couple of days for the devices to adjust, or possibly doing a full zwave repair might speed that up.

How far away is the next closest device that is routing through that one dimmer? My house is a 2 story with around 1300 sqft footprint. Most of my device will direct connect. Even the garage controller (ZEN16) which is about 30-40ft away is direct connecting right now.

Download the Hubitat app