Apple TV on Airplay

With the latest update, Apple TV is now available in Airplay. It shows up in the app. I select it. A device is created. Go back into the app and do Airplay pairing. Code shows up on TV. Enter code hit the disc to save, hit confirm and everything seems to be ok.

but when I go into the device it self and try to do a speak, it just pops up on the TV with another code. Happens over and over.


1 Like

interesting, mine works w/o issue. Mine is an A2169 running 17.0. Also did you do both the airplay and raop paring?

Mine is a 4K. I did not do the roap. Didn’t know what that was.

Redid the Airplay pairing and did the Raop pairing. That solved the problem. However sending tts to the unit doesn’t work. Could be cause I have pods linked to it for sound.

Don’t really need this as if the unit is on then I’m watching tv and don’t want that to be interrupted. So no big deal.

The app required two separate codes for Apple TV (AirPlay and RAOP), at least mine did. I'll make a change to explicitly say so.

Just curious. If I send a speak command to the Apple TV it should sound on whatever speaker system the TV has, correct?

Once I did both the AirPlay and RAOP it seemed to connect. I can change the volume and see it change on the TV. But no speak sound.

The device pairing section where you can start pairing and start raop pairing is greyed out for me.

What does Reinstall Dependencies do?

Start pairing and raop pairing are no longer greyed. But now say Redo Airplay pairing and Redo RAOP pairing. When I attempt to re-pair, hit save button and confirm pin, I get a pairing failure.

What does Reinstall Dependencies do?

If RAOP pairing is greyed out, it's waiting for an AirPlay code.
Just click Start/Redo pairing button and it will send a PIN request to the Apple TV again. There's no downside to doing it over and over as far as I can tell.

If you got to a point where its asks for PINs, nothing useful :slight_smile:
Well, it downloads some bits and pieces of code that don't come in the main hub firmware distribution. Those bits are pretty large, and they're only used if AirPlay is used. It makes sense for them to be separate.

Can you PM me the hub id, and I'll take a look at the engineering logs?
Also, what is the Apple TV model and the firmware version it's running?

Thank you for responding. I actually have done that several times. To no avail.

I have (1) AppleTv 4k gen 3, tvOS 17 that it did work , (1) tv 4k gen 1, tvOS 17 and (1) Tv Hd, tvOS 17 that it did not work.

Additionally, I have a Vizio tv with AirPlay that it did work on. I have a new Mac intel version with latest os that it did not work on. I will PM you my info.

Thank you!

Did you enable Airplay in System Settings -> AirDrop & HandOff -> Allow AirPlay for anyone on the same network? It is disabled by default.

1 Like

So, I thought it was enabled on my Mac but it was not. It is enabled on all my other devices. Thanks for reminding me.

Unfortunately, I cannot test it as my Mac is checked in the selected list of devices but now does not appear in the device pairing list.

As a matter of fact several of my other devices appear on the device selected list but do not show on the pairing list.

There have also been a couple times where my devices fail to show in the selected list.

Not sure what is going on or if I am not enabling a function somewhere else. But when this new feature showed up on one of the recent firmware updates they just automatically populated.

Sometimes an HE reboot fixes the issue.

Found a bug, the logic may think you already paired a device before, but the pairing really belongs to a different AirPlay device. A do-over (re-pairing) will create the proper entry, but the status of pairing is wrong. Will get it fixed in the next build.

Try going back into the Notifier app and pressing "Done". For me, that allows the Notifier to speak once on the Mac each time I do it. @gopher.ny, I assume this is still on your list?

Notifier app?

What is generally used to send voice notifications. just got released, it should take care of the PIN pairing confusion between devices.

Sorry for my thick headedness. But, I think I am missing you on this.

I use echo speaks for my echo devices. All of my notifications for announcements are done through webcore.

It is, although it's not the highest priority item at the moment. I never thought of using Mac as a notification speaker...

So, I downloaded the release and no go. As before, my Vizio Airplay enabled TV and my Apple TV 4K Gen 3 are working. But cannot get my Apple TV 4K gen 1 or Apple TV HD to connect. Still get a connection failure error in HE. One thing I noticed on my paired Apple TV 4K gen 3, the RAOP pairing now says "Start" instead of "REDO" and the Airplay pairing says "REDO".

I checked all of my settings on the two Apple TV's that aren't paring against my one that is and everything is the same even "Same network" settings.

Perhaps this is on me.

This is obviously not a crucial function for me. Just trying to help out the HE team for any bugs if there are and it's not on my end.

The MAC notification part I get. Just strange that it shows up on the Select Airplay device list and doesn't show up on the pairing device list like it had before.