Anyone Using Mitsubishi WiFi Controllers / Apps (MELCloud) in Europe

Acvtually, I am basing my code on the Can... settings, that's what I was looking for... i.e. there isn't one of these for Auto.

Am thinking I will use the modelSupports... settings (for auto only) and wait for people to say it doesn't match what their unit can support...

perhaps useful:

I haven't made any progress myself, down with long covid

1 Like

Thanks.

Must have been a different dev who implemented the notion of the automatic fan speed and the fact that cool, heating and dry modes (can) are possible... :roll_eyes: Not to mention the mixture of sensitive and non-sensitive info....

Still thinking will run with the modelSupports setting as the indicator for whether auto mode is an option I should offer in HE...

Things are pretty good here in Aus re COVID, at least in NSW, and Victoria is coming out of another lock-down. Personally it was nice to work from host most of last year, but would give it up in a heartbeat for the countless who have had a much more difficult time, not to mention those who have lost loved ones.

Hi,

Just wanted to let everyone know I have now released a new set of drivers that cover all three Mitsubishi platforms, including MELCloud. The thread for the new drivers is below, and includes links to the drivers and installation instructions.

My intention is that these will replace the one's I previously developed just for MELCloud, but I will continue to support the MELCloud drivers for sometime, allowing people plenty of time to make the transition. If anyone is keen, you can make the leap to using the new drivers now, although I have not worked through the best way to transition, whether you can simply switch the driver for existing devices, or whether setting up afresh would be the way to go. I will try to look at this soon, unless anyone else would like to take a look and let me know their experience.

Thanks again for everyone's support, I have really enjoyed developing these with everyone here and learning so much along the way.

Simon

1 Like

Hi, thank you very much for your work.

I quickly tried just to copy/paste the new drivers over the old ones, and it didn't work out.

No errors or anything. The device doesn't do anything if I try to change temperature or fanspeed.

Maybe tomorrow I can start the installation from the scratch.

1 Like

Thanks for taking a look @mikkomattip . Thinking about it now, you may need to refresh the parent device, wait about 60 seconds and try again. If that doesn't work, then try from scratch.

Simon

I did try that right away and it didn't help.

Ok, was a shot in the dark. Hopefully the fresh start will work. Thanks again for taking a look.

I installed the new version with HPM and it was smooth and easy.

Same thing with the language happened than last time. When I change the language to Finnish, on MelCloud-app it's in Swedish. :smiley: But it doesn't matter.

Other thing was on a dashboard was a long delay to set the temperature. I was able to change mode and fanspeed but not the temperature.
image
About five minutes and several page updates later it appeared and now everything works very well.

Thank you so much @sburke781 for your great effort!

I see you are very very good at what you do. I don't know if this is a right forum to ask. But I use android phone. I'm pretty jealous to iphone-users and their Homekit app. I would love to have these Hubitat dashboard things on my phone's homescreen as a widget. It's not user friendly to open a app, then dashboard, choose right one and then do what you where looking for.

Do you happen to have any solution for this or will I organize fundraising to pay you to do somekind of widget-app? :smiley:

1 Like
2 Likes

Worth a shot, depends on exactly how many controls you want though... Perhaps if I get around to setting up presets that might be a workable option... Alternatively you could take a look at the android app developed here on the community. Can't say I've tried it or it will do what you need....

Thanks again for taking a look at these drivers @mikkomattip. I was finishing work earlier when I was responding, wanted to give a more detailed response to your post...

I've logged an issue for this. Can't guarantee when I will get to it, but hopefully once we get over the hump of the release and a couple of the high priority features like local control I can get back to it.

Great to hear it eventually came good. I am still keen to see a seamless setup process, so have logged an issue for this as well. Will need to assess the priority on this one...

Thankyou. I have certainly enjoyed using my expertise to impact my own home automation, but even more of a kick out of helping others with their setup.

Probably not my area of expertise, but as @mike suggested, Tasker may provide you with an option, depending on your technical expertise and inclination for that kind of tinkering. The app I was referring to in my earlier post is below. May be worth a look, but can't guarantee it suits what you want...

As always, if you have any issues or suggestions, happy to hear them.

Simon

Not a complete solution, but it is possible to add a link to a specific dashboard to your homescreen. Next to that, I use "http shortcuts" to create button widgets that make requests to the maker api (can use this to trigger (virtual) buttons etc).

1 Like

FWIW, I did a bit of investigation for my airco's. The (integrated) wifi modules (MAC-567IF-E) do not seems to provide a local API (e.g. a la ECHONET lite), but only melcloud functionality.

Hmm... I certainly have promising examples for Kumo (U.S.) and MELView (Aus/NZ), at least some notes or code to try and convert to HE, but can't remember for sure whether I have an equivalent for MELCloud in Europe. Will do what I can, but ultimately it is dictacted by what Mitsubishi offer. Thanks for the info....

One more bug (I guess).
In x period of time on dashboard thermostate goes offline.
All I have to do is set mode to something and in a second it shows the correct mode and temperature.

Fan is working all the time.

That is strange. I'll see what I can find, otherwise I may need to get some logs from you around the time that it happens.

Weird to think it is almost 12 months since I started this thread....

A couple of updates for those in Europe...

A reminder that I released a new set of drivers that bring together Europe, the U.S. and Aus/NZ under one set of code, and will be the drivers I will be supporting going forward. These are now available under HPM.

I have released a fix to these driver to (hopefully) correct a bug that @mikkomattip picked up with the thermostat mode being reported incorrectly as "off" (see the last two posts), corrected in version 1.0.4 released in the last 2 hours. Thanks to @mikkomattip for your assistance in getting more details on this issue.

I will be looking at the delay in temperature updates next, also logged by @mikkomattip.

With regards to the language issue @mikkomattip identified, I have thought more about my response:

Prioritising this behind enhancements is not the way I would like to prioritise issues like this, I will be looking at this ahead of any enhancements. Still can't guarantee timeline for getting it fixed, but will be fixed before I look at expanding the drivers.

Finally, I am wondering whether the recent Android widgets released as part of HE platform update 2.2.8 may eventually satisfy your need for easy access to thermostat controls @mikkomattip? Even if the current widgets available do not provide the full Thermostat widget, maybe some virtual switches along with some rules could help be used to control mode at least?

I am thinking that some extra commands for adjusting temperature up and down may be useful for this kind of purpose....

Anyway, that's probably enough of any update. As always, happy for any feedback or suggestions. Feel free to continue to post here or on the thread for the new Unified Thermostat drivers.

Thanks,
Simon

1 Like

Hopefully tonight's fix (v1.0.5) will address an issue @mikkomattip picked up where the switch to heating in a MELCloud system was switching the unit off.

There is more to do with temperature's not being handled correctly, again thanks to @mikkomattip for his help with testing this and providing feedback on changes as I release them ... Along with users in the U.S....

Download the Hubitat app