Another Thermostat Scheduler (widget) bug?

I am unable to change thermostat (Zen) Fan Mode (On/Auto) using the widget. The option pops up but it does nothing. Switching it at the thermostat driver level works. Thermostat is set to Celsius.

@bravenel Can you confirm it as a bug ?

Do you see anything in the logs when trying to perform the action in Thermostat Scheduler? You may need to turn on some logging options to see more details appear.

It may also be useful to mention what software version you are running on your hub.

Switching from "On" to "Auto" works and logs show "Thermostat Fan Mode Auto", but switching back to "On" from "Auto" does nothing, no logs (a network request is sent though).

I am running the latest firmware, but the issue started before 2.2.9 was released, I just did not report it earlier.

I figured out the bug for you. The request sent when clicking on the "Fan On" button sends " on" value, notice there is a space before "on". When I removed the space in dev tools it worked.
Now, can you fix it for us?

Thanks

Screenshot from 2022-04-01 08-21-25

What widget are you referring to? Mobile app? What kind of phone?

I am referring to dashboard thermostat widget. It is in the app and on the web through a browser since the app seems to be a WebView.

Screenshot_20220402-073302

I am not the only one having this problem.

Ah, that is a dashboard tile (not a widget). Not sure who’s the best staff member to bring this to. Tagging @bobbyD.

You are definitely into something here. I can confirm there is a bug when changing the fan mode from the Thermostat tile. Is not specific to "on" command, but subsequent commands. I have referred this issue to our engineers and you could expect a bug fix in an upcoming release .

3 Likes

Please update to the latest release (.135) and see if your problem is resolved:

1 Like

I upgraded t0 2.3.1.135 and still have problem with switching fan modes on my Honeywell T6 t-stats. It works fine if I send fan mode changes directly from the device page, but does not work when using either dashboard nor when using a thermostat controller for the T6. It really seems to be related to the extra space in the fan modes as described above.

I don't know if this helps, but I did write some RM scripts several months ago which worked around the problem. I'll attach the screen shot in the hope that it helps better describes what worked for my configuration.

I removed the tile and added it again, it seems to work for me now.

1 Like

Just upgraded to .137 and unfortunately it still doesn't work. "auto" and "on" work OK, but "circulate" still doesn't work. I'm wondering if my problem may be specific to the driver. I'm using the stock "Honeywell T6 pro Z-wave thermostat" driver, which works for me since that driver recognizes "circulate" as an available fan mode (during configuration) and successfully processes "circulate" fan commands from either the device page or from a RM script. (However doesn't process "circulate" command directly from a thermostat controller without the use of the aformentioned RM script)

I've also tried using the generic Z-Wave Plus Thermostat driver, as recommended in several posts on the forum (BTW, hit the configuration button...also reset the state variables beforehand using "device" driver...and deleted/readded thermostat tiles in the dashboard), however, I can never get it to recognize "circulate" as an available fan option during configuration, nor to process a "Fan Circulate" command from the device page.

So possibly are there still inconsistencies for "circulate"/" circulate" in the different types of drivers available....and/or in the dashboard tiles available? Please let me know if I can provide any more information and if you can provide any more suggestions. Be glad to help in any way I can.

Still doesn't work? Previous javascript code may have been cached in the browser, but it should have aged out by now.

1 Like

Still not working. I rechecked fan behavior this AM

  1. "On" and "Auto" work from dashboard for both the controlled and controller thermostats.
  2. "Circulate" selected from dashboard correctly sets mode on the controller thermostat dashboard tile, but the controlled thermostat file and the controlled thermostat dashboard tile do not change fan mode at all, nor does the T6 thermostat physically change fan mode.
  3. If I physically set "Circulate" on the T6 thermostat, the controlled thermostat dashboard tile successfully changes immediately to "circulate" as the fan mode. (status is being received and processed by the hub app)

Download the Hubitat app