Annoying BOGUS warning when background refresh AND geofence disabled on iOS app

I have geofence disabled (I do NOT want it), location is also off on iOS device. Now EVERY TIME I start the app an annoying warning (with sound) pops up saying geofence cannot be enabled when background refresh is disabled. Huh? I have geofence disabled and do not want it so why the repeated pointless (and incorrect based on my settings) warning?

1 Like

Can you check if you have the “Enable GeoFence” option turned on under the Hubitat App’s Settings page? Turning it off should resolve the issue.

I just tried disabling Geofencing for the Hubitat app on iOS, and then I also received the error you described. Then once I disabled the “Enable GeoFence” option and re-opened the app, I did not get the error.

1 Like

In my post I pointed out the geofence is disabled along with location access in iOS. I do not want any location based features. Hence my post! And I double, triple checked before replying. So clarifying: location services are blocked, Hubitat geofence is disabled (and not wanted) but the result of no background refresh (also not wanted and unnecessary wo geofence) produces an irrelevant and annoying pop up warning every time I open the app. This is clearly wrong and not something I can disable from the API. Note that even if this warning was relevant I should have a "don't show again" option ... so double failure IMO.

Odd - when I disable the geofence in the app, the error message no longer appears for me.

Even more odd: I opened the app a few times yesterday, with no changes my end, and I noticed the warning appeared to be gone. I optimistically thought that my report had prompted a fix. :wink: Not a smart presumption on my part since there was no update to the app. However, today the annoyance is back. I'm running iOS 16.5 with all apps updated. I had hoped that this would be easy to reproduce and therefore fix but as a retired software developer I realize we are now in more difficult territory with both device specific dependence and inconsistent behavior. That said, the warning appears most of the time with only a couple of exceptions yesterday. [wish I could see the source code :slight_smile: ]

Inconsistent behaviour is not pleasant…. Tagging @moncho1138

1 Like

Maybe something got corrupted on in a settings file somewhere buried within the app. Have you tried removing the app to clear it off the device and then reinstall it again? I have found this sometimes helps resolve the problem when I encounter odd behavior in an app.

Thanks for the suggestion even if it seems to be 'clutching at straws' at this point.
UPDATE:

  • deleted app from device
  • reinstalled app
  • checked app specific settings and noticed background refresh button on but 'greyed out'
  • Temporarily enabled iOS background refresh so I could disable all app specific background refresh settings (including Hubitat) then disabled iOS background refresh for all.
  • verified Hubitat 'use location setting set to "never"
  • started app, logged in, and set geofence OFF
  • closed app then reopened several times and the problem is STILL THERE!

I realize that I lock down my device in terms of privacy, tracking, and specifically location but it seems that this should be reproducible on other devices with the same settings. I have a sinking feeling that my only hope only a developer willing to take this seriously.

[edit] I installed the app on a cheap Android tablet and tried to match the no background or location settings and I noticed two things:

  1. The app installs with geofence disabled by default vs iOS enabled!
  2. I do not see the annoying warning which FYI is a push notification on the iOS device.

Thanks again for the suggestions so far.

1 Like

Sorry for repeated updates but this thing is driving me nuts!
In addition to posts so far I have now uninstalled and reinstalled the mobile app twice. In addition I deleted the mobile device association then set up a new mobile device and repeated the disabling of geofence, background app refresh, AND location ("never"). Also rebooted hub and hard rebooted iPhone.
No matter what I do I get an EXTREMELY IRRATATING push notification every time I open the app saying that geofence cannot be used with background refresh disabled.
If I were not so invested in Hubitat and the local operation feature this thing would be history. Very disappointed and looking for alternatives.

What do you use the app for? There are alternatives …..

Also, as an FYI, if you were to use geofencing that data isn’t stored on anyone’s cloud. Although, it does use Hubitat’s cloud servers as a relay. Much like any other use of the app.

I personally use the Apple Home app for device control and home/away. And OwnTracks for more sophisticated geofencing.

2 Likes

I'm honestly a bit confused at this question but as politely as possible, I chose the Hubitat solution based on #1 ability to operate locally without sending requests half way round the planet and #2 flexibility. When choosing an app it seems logical that a good starting point is to use the existing app developed for the product and I would need a VERY good reason to use an alternate.
Furthermore, until I turned off iOS background I was perfectly happy with the Hubitat app. It did what I needed and, apart from curiosity about the rate of updates, I had no reason to look elsewhere.
I will add that this is a clear bug that needs to be fixed and the fact that there are other apps out there is IMO irrelevant in the context of this forum. I hope that others reading my response agree.

The app works locally while you’re on your LAN. The rest of the time it uses Hubitat’s cloud as a relay. Same with geofencing.

It's been a while and several updates have been released (hub and IOS) but this annoying BUG is still present (see my earlier lengthy bulleted reply). Is there any way/place to report this as a hard bug or get some traction on it? Not sure if I mentioned earlier but I have an Android tablet running the app with the same location, background, and geofencing DISABLED and no errant warning. So this is apparently just an IOS BUG, Any help on directing this to the developers would be much appreciated.

The mobile app is being entirely rewritten. While bug fixes for the old app may still be possible, this one seems difficult since no one else has been able to reproduce the behavior you describe. Your best bet may be trying the new app if you are comfortable with that beta (the version 2.0 iOS mobile app, not the current mobile app beta or the hub platform beta) and report the issue with steps to reproduce in the appropriate forum category if you still find the behavior there.

2 Likes

Thanks for the quick response and finally some hope! I expect no one else reproduced this is due to nobody being prepared to take the time to make their settings as aggressive as mine namely, ALL background refresh disabled (IOS), no location services enabled, and geofencing disabled in the app. Under these conditions I expect no spurious warning or perhaps and one-time "do not show this again" reminder. I'll check v 2.0. Thanks.

I think @aaiyar was asking specifically: if you don’t want to use the geofence, which features of the mobile app do you use?

Push notifications are one possibility. Many users prefer an integration with Pushover over the Hubitat mobile app. Some people don’t want push notifications at all.

Dashboards are another possibility, and can be accessed directly by their URL, no need to use the mobile app.

1 Like

I use the dashboard for various device types and enable notifications which is fine as long AS LONG AS THEY ARE VALID. The bug I am reporting is in fact a push notification on IOS but the logic that generates it is flawed such that EVERY TIME I open the app the bogus push notification pops up over the screen [with beep] and I need to get it out the way before doing what I want, For completeness, as well as mundane dashboard stuff, I have Zigbee/Zwave leak sensors and I run the user-generated (and tweaked by me) Flume driver so that if leaks are detected from any source I get a push notification and a rule runs a shut-off valve. This all works great if it weren't for the spurious geofencing annoyance. It's frustrating that it's likely one line of code changed to: if ((geofencing == TRUE) && (background == FALSE)) then warn(ONCE) instead of [apparently] if (background == false) then warn(ALWAYS)

Since you do use the app for its push notifications, your best bet is either to sign up for the iOS app beta as @bertabcd1234 suggested, or wait for the new app to be released in the App Store.

There is a lot of developer effort currently being put into the new mobile apps for iOS and Android, which may not leave much time for squashing bugs in the current version of the app (assuming you’re right that this would be an “easy” fix, which may not even be accurate).

Or if you’re interested in hearing more about the pushover integration, just ask.