Android App 1.4.4 issues

Despite my attempts to turn GeoFence Off, the app does not remember this setting, and must be turned off each time time app is started.

In a related note, if set to "permit location services only when this app is running", the app complains each time it is started that "This app needs location access", perhaps because it does not remember that I disabled Geo-fencing.

I just checked my app and turned off geofencing and rebooted the app and my phone and it remained off when I opened up the app again. But, when I disabled it, I clicked on the dash and then went back to settings and confirmed that the toggle was still off. Is this what you did? It worked for me.

1 Like

Sorry, no amount of logging out, power cycling, turning the phone off for a bit, or even immersion in 3 meters of water at the bottom of the pool seems to make any difference.

"This app needs location access" is the first symptom upon starting the app, then when saying "OK", one gets the hubitat logo, followed by the same error message again "This app needs location access", and then the "Settings" screen that shows that "Enable Geofence" is back on again, and "Allow rotation" is also set to "on".

Pixel 3 128 GB running Android 10, with the Jun 5 2020 security update.
Couldn't be any more vanilla an Android platform... 'cause "Google".

That is exactly what I'm running on a samsung. unless there's something with the google UI. Might I suggest that you clear the cache and appdata or start uninstall the app and reinstall. If you're using presence, might want to create a generic presence device to replace removing the app data from your phone so that you don't break your rules.

1 Like

Same 2 issues for me as well. I posted this a couple week ago and don't recall getting any hits

Clearing app cache/data and uninstall/reinstall has not solved either issue

Pixel 2, fully patched v10

So, Pixel 2 and Pixel 3 both.
I think I can say with some level of certainty that Google's version of android is about as "vanilla" as one can ever hope for.

I wonder what derivative off-brand Android this was written on and tested on?

Perhaps the developers want to send each of us a version of the app with far more verbose logging of this initial process concerning "location" and "Geofence".

Yes, tested my wife P3 XL, same issues


Hmm .. I have a Samsung and could not replicate the problem.
Tagging @bobbyD - can you check it out?

For the record, the developers are working on this issue, after confirming that the problem was not just real, but consistently repeatable.

The problem I'm having with the Android app is that the geofencing behaves erratically. It either thinks I'm away when my phone is sitting on the back porch 10 feet from the back door plugged into a charger while I'm working in the garden, or I go somewhere and it fails to recognize that I'm no longer away when I return home. Either way I set off an intrusion alert because either the Android app or the hub is malfunctioning. I'm not sure why I'm persisting with hubitat. Maybe it's because the warranty has expired and I can no longer get a refund. This geofencing issue is just the latest of the problems I've experienced in less than 2 months, starting with an unanswered support email. I'm finding it rather difficult to forgive a bad first impression when the problems keep coming with no end in sight and no support. Right now it's unplugged and serving time as a very expensive paperweight. It'll remain that way until I get some meaningful support

Sorry for offtopic post but I didn't want to start another thread to ask.

It seems I remember you used to be able to glitch the android app and it would give yiu full access to the hubs menus and function. Is this still possible and does anyone know how to consistently do it?