Ancient Proprietary Zigbee Issues (GE Link + Iris V1)

Problem: I can't seem to keep Iris V1 motion sensors working.


Most of my stuff is ZWave, but I have a few devices on Zigbee. Unfortunately I have about zero which are quality, modern, non-proprietary devices.

I have two ancient GE Link bulbs which have been fine for a long time, despite their many flaws. This has been my entire zigbee mesh for 6 or 7 years.

I added a Sage Doorbell sensor, which has been and continues to be flawless.

I recently bought a lot of Iris V1 motion sensors for cheap on Ebay. I added four of them to my network and they worked great. When I added the rest of them, all but one stopped working.

I believed it to be a repeater problem because I have the HE in the basement and most of the rest of the devices. I was thinking I'd get a couple Ikea repeaters until I found the thread about building repeaters out of XBee devices. I have a couple of XBee Series 2B Pro and a couple XBee Series 2 Pro sitting around from a past life, so I configured the two 2B Pros. One for repeating and one for scanning and graphing (read: connected to my computer). This is great, by the way, and I feel like it makes use of a bunch of hardware I have in my garage just sitting around.

The doorbell and the light bulbs show up, and I was able to get the mesh to re-fold using the XBee as a repeater without issue. But I can't get the Iris V1 Motion Sensors to show up at all, and I can't get the devices show any activity in HE either. All but one of the sensors have been inactive for over 3 days, some of them have never checked in at all since pairing.

I just pulled the GE Link bulbs and have noticed no difference as well.

Thanks for looking! I appreciate any advice.

Have you tried to factory reset and re-pair one of the motion sensors?

Lots of Zigbee bulbs, at least older ones, are reported to be problematic routers (repeaters). The GE Link bulbs are reported to be particularly bad. You can find a lot of similar complaints here and in other forums with a search. They'll work fine on a Hue Bridge, or some people use a second Hubitat; in either case, the idea is to not mix them with other (non-bulb) Zigbee devices, thus avoiding this problem. (I know you said they've been fine for years, but obviously not all of that time was on Hubitat. They can work fine under certain circumstances, this likely not being one.) Do make sure you still have enough Zigbee repeaters left on your "regular" network if you do this.

The Iris v1 sensors are technically supported, but I've read of people having mixed luck with those too. This may be related to firmware version; if you previously had them working fine on Iris, they'll likely be fine (I think the issues I've read about may be people's buying them "new" after Iris shut down with no way to update firmware--just a guess). The bulbs are quite likely to be the source of your inconsistent behavior.

1 Like

Factory reset is a good idea. I haven't done that yet (knowingly) because the documentation for Iris v1 motion sensors is near absent from the internet. If you know of a way to reset these devices, or have a lead on a manual for the MOT801/901 sensors, It'd help... as it is I'm shooting in the dark.

Edit: I did stumble upon a youtube video for doing a reset on the Iris V1 -- Pull battery for 10s, reinsert battery and press the tamper switch 8x at a 1s interval. Doing so causes the LED to flash in a "heartbeat" pattern.

Yeah, good reminder about the zigbee light network.

My motion sensors are definitely ebay purchases "as new" so I suspect the firmware might be the problem.

I pulled the GE bulbs out of their sockets yesterday and the mesh doesn't show them anymore. However motion sensors are still almost all missing.

After doing some button and battery fiddling blindly I was able to get the HE to reacknowledge a couple of them, and I'm seeing events from the sensors in the log (temperature, tamper, and motion). However, I'm still only able to see one of the sensors in the mesh. This is strange -- after repeating the same procedure to reset the devices, they are reactivated in HE but don't show up to the XBee graph.

I assume you mean on the getChildAndRouteInfo diagnostic page on Hubitat? If so, this doesn't always show all devices. Rumor has it it may be related to which have been "active" recently, but my experience doesn't seem to line up with that 100%. I don't have a good answer. An Xbee with XCTU is normally better, but I occasionally notice the same there, too (or at least I did when I was trying to verify the route of an old Xiaomi device). Everything was working fine; I just couldn't verify its route. If that's your only problem, I wouldn't worry about either one too much. If you still do have problems, I'd make sure you still have enough repeaters without the bulbs, or you could try the old trick of forcing devices to find a new route by disabling your Zigbee radio (or powering down the hub) for at least 20 minutes.

1 Like

I'm not familiar with getChildAndRouteInfo, just looking at the XCTU graph. Is that a function I can call in a custom app or something?

It's an undocumented diagnostic-ish page:


You can find a bit more about it here with some searching, but it basically shows you child devices (end devices that connect directly to the hub), neighbor tables (routers/repeaters that connect to the hub), and route tables (routes for devices it knows about) in list format.


Very Cool. Are there anymore of these undocumented features?

Probably, but this is the only page I can think of that's like that off the top of my head. :slight_smile: (Nothing like this for Z-Wave built-in, for sure!)

1 Like

Very cool. Thanks.

Parent child parameters
EzspGetParentChildParametersResponse [childCount=2, parentEui64=0000000000000000, parentNodeId=65535]

Child Data
child:[Doorbell, 5044, type:EMBER_SLEEPY_END_DEVICE]
child:[Basement Under Screen, F55E, type:EMBER_SLEEPY_END_DEVICE]

Neighbor Table Entry
[Xbee Pro S2b - Grapher, 6D2B], LQI:255, age:7, inCost:1, outCost:0
[XBee Pro S2B, E06A], LQI:255, age:4, inCost:1, outCost:3

Route Table Entry
status:Active, age:32, routeRecordState:2, concentratorType:Low Ram, [XBee Pro S2B, E06A] via [XBee Pro S2B, E06A]
status:Active, age:64, routeRecordState:1, concentratorType:Low Ram, [Xbee Pro S2b - Grapher, 6D2B] via [Xbee Pro S2b - Grapher, 6D2B]
status:Active, age:64, routeRecordState:0, concentratorType:None, [null, C58A] via [XBee Pro S2B, E06A]
status:Active, age:64, routeRecordState:0, concentratorType:None, [null, 651D] via [XBee Pro S2B, E06A]
status:Active, age:64, routeRecordState:0, concentratorType:None, [null, DC67] via [XBee Pro S2B, E06A]
status:Active, age:64, routeRecordState:0, concentratorType:None, [null, 81B6] via [XBee Pro S2B, E06A]
status:Active, age:64, routeRecordState:0, concentratorType:None, [null, E806] via [XBee Pro S2B, E06A]
status:Active, age:64, routeRecordState:0, concentratorType:None, [null, 3228] via [XBee Pro S2B, E06A]
status:Active, age:64, routeRecordState:0, concentratorType:None, [null, 27F5] via [XBee Pro S2B, E06A]
status:Active, age:64, routeRecordState:0, concentratorType:None, [null, 23AE] via [XBee Pro S2B, E06A]
status:Active, age:64, routeRecordState:0, concentratorType:None, [null, B853] via [XBee Pro S2B, E06A]
status:Active, age:64, routeRecordState:0, concentratorType:None, [null, CEB6] via [XBee Pro S2B, E06A]

There are a suspicious amount of [null, xxxx] entries in my route table, which makes me think it's the motion sensors.

My understanding is that those are usually devices that are routing through something and think they're on your network (and are, I guess) but aren't in your hub's Zigbee database. That could be because they were removed from Hubitat, but the devices weren't actually reset (e.g., they were offline at the time and brought back on later so they didn't respond to the request to leave and haven't been manually reset since). I don't doubt that there could be other reasons, especially with an Xbee where you could have various settings about how aggressively it does or doesn't "prune" old devices out of its child devices.

1 Like

well... if he told you, they wouldn't be undocumented... :speak_no_evil:

Is C58A one of your zigbee id's of our V1 sensors? [null, C58A]

I have no idea. It doesn't show in my XCTU scan, and when I search on the HE devices page it doesn't find anything either.

I searched for all of the right hand arguments in those [null, xxx] tuples and none of them actually show up anywhere. The E06A identifier does match to my XBee Pro S2B, and that shows up in XCTU as well as in HE devices list by search.

Yeah, it would still be undocumented by Hubitat.

I can tell you that I have a ton of Iris V1 devices on my system and they are all rock solid. I see a lot of them in my routing table and they are all functioning as they should for the repeating devices (V1 Smartplugs) as well are the end devices. I haven't counted but I bet that I have 20 V1 Smartplugs and every window in the house has a Iris V1 contact sensor on it. What I do not have is a single bulb on that hub. When you have a problem on a system that has bulbs paired to it, more times than not they are the culprits.

@Otto_Mation glad to hear that you've had success, they're the only sensors I can buy for cheap in large enough quantities to be meaningful to our home. Are your Iris devices those which you've previously had connected to an Iris hub? Or bought as "new in box" on ebay like I did for mine?

My current goal is to move all the smarts out of the bulbs and into the switches or appliances and for now I've taken the GE Link bulbs out of service.

1 Like

My Iris V1 devices were mostly paired to an Iris hub but not all of them. I have received them from multiple sources including directly from the Iris developers over time. You can separate your bulbs and put them in use by putting them on a separate hub and use HubConnect to connect them to your main hub. That should clear up your problem and let you use your bulbs for now. You say that you removed them from your system, that may explain the null devices.

I only had two bulbs, and they're still in the HE device list just not physically plugged in - 1890 and 4557 are their network ids.

Here is what I would do. Remove the bulbs from the hub. Then turn the hub off for 20 minutes. This will put your Zigbee devices in panic mode. When you turn the hub on it will rebuild the Zigbee routing table. Sort of the equivalent of a Z-Wave repair.

1 Like