Am I Alone in giving up on Room Lighting?

Same here. I think part of the problem is that the terminology used can be confusing, and very inconsistent. It's not at all clear that "Activate" and "Turn Off" refer to the app as a whole (or that you're even creating an app in the first place). These terms should be complementary. Either "activate" and "deactivate" or, "turn on" and "turn off". This is further exacerbated by the obscure option "Use preset settings for Turn Off" which magically removes the "off" column from Device Control and adds a "Preset Off" table (which is not easy to discover) that uses the "Activate" terminology when it ought to be "Deactivate" or "Off".

Then the plethora of options, and the inconsistencies in the UI. For example the option Activate as Group with ZigBee Group Commands only appears after you have specified a name for the Activator Device on the prior screen. Not at all apparent or initiative, you have to discover this by trial and error.

I'm sure RL was a non-trivial app to write, and clearly it's very powerful once you get your head wrapped around it, if you can persevere through all the quirks and confusing UI. Sometimes though, it feels like they created this great powerful app and then made it as unapproachable as possible. I know that wasn't the intent, and there are limited resources to put into the UI (and documentation), but unfortunately it drives people away.

I've vacillated between RM and RL for certain tasks for a long time. Just last night I tried moving an onery RM rule into RL. I thought I got it right, but of course it didn't work as I expected, and some lights didn't turn off this morning. I'll probably persevere and get it working and hopefully learn something in the process, before frustration sets in and I go back to RM again.


When RL first came out I tried very hard to like it. Every time I thought I'd wrapped my head around it, something didn't work right and I couldn't figure out why. To be fair, it turned out that a few of those were actually bugs that have since been fixed.

I have a couple of very simple light automation in RL that work OK. And I found that it works pretty well for scene transitions, although it takes me a bit of tweaking to get them right. For example, I have my kitchen lights transition from daylight white to warm white over about 5 minutes at sunset. But I trigger the transition from RM. More complex automations just seem easier to write in RM.

I've only glanced at it. Before RL came out I had already written my own room lighting app and it has continued to evolve to fit my needs. :wink:

I started noticing a few days ago a RL rule that I spent a week or so working on/ wrapping my mind around (and is the basis for three other RL instances) have all stopped working. I haven't touched these rules in months, they just stopped working randomly. I think rather than beat my head against the wall trying to figure out what changed, I'm just going to transition them all back to Rule machine or Simple Automations. I like the IDEA of room lighting, but it's just not working out.

Have you tried hitting the "Done" button at the bottom of the RL page to reinitialize the app? Also suggest enabling logging and debug logging.

1 Like

Yes, Update, activate and done (to be honest I never understood the difference so I hit all three to be sure. Logging is even weirder. The logs show the switch device was turned on, even though it wasn't, and from the device page it also shows off.

The rule in question is a Fairley straight forward one:
When there is motion on any of 2 motion sensors, turn the desk lamp on for 7 minutes, when all motion stops, turn off. No Times periods, modes, etc. a quite simple motion based on an off. Un fortunately I'm not where I can grab screenshots for a few more hours. This rule has worked reliably for at least 6 months, suddenly two days ago it just stopped .

Activate starts the RL app. Both Update and Done commit any changes to the database. Done closes the page as well.

RL doesn't just start to make up events. You should start a new thread, post pictures of logs of both RL and devices. Also post a picture of the device Events page.

1 Like

That is what I thought. but it definitely said switch on, and the device definetly wasn't, and the device page also said off..

I will when I get home later. It's weird how suddenly it stopped working and nothing has changed.

I've seen this numerous times as well. I generally have all logging for all devices turned off unless I'm trying to debug something, so I've never been able to post any meaningful info or logs when it happens. But you're not alone.

I'll dig into it this afternoon. I'm not so sure it's a made-up event so much as maybe a log entry for what RL did, but there is disconnect between RL actions and what the device does? I don't know, maybe I'm not fully understanding what I'm seeing, but having someone else also see it at least confirms my suspicions. Hopefully someone can help me walk through it and figure out what's happening (or not happening) .

If the RL gets stuck in the "Active" state somehow, it is possible that subsequent activations will keep getting ignored depending on the settings. May just need to go in and manually turn it off using the button in RL to reset it.


I'm not sure it's an RL issue as opposed to a general platform issue.

HE keeps track of a device's state, and assumes it is correct. But it isn't always correct, and never can be. The device is the authority of whether it is on or off (or any of its other states), not the hub.

I understand why the hub does this, but it would be nice if the hub had a mechanism to periodically query all (or selected) devices to make sure it is in sync with reality.

I've seen the same issue occasionally in RM, and even in the All Off sample app that uses multiple tries to turn things off. I've seen All Off complain that something is still on when it is in fact off, and not attempt to turn something off that is clearly still on.

1 Like

If your devices support the REFRESH command, then it is pretty easy to create a Rule that calls REFRESH periodically. I have some old Lowes Iris v2 Leak Sensors that do not update their battery status reliably. I simply created a Rule that runs twice a week to call refresh() on all of these leak sensors.

Note: I am not recommending doing this type of manual polling at a high frequency. But, if you've got a couple of devices that sometimes are out of synch, calling refresh() once a day might be all that it takes to keep things from getting too far out of synch.

1 Like

I've done that, and it does seem to fix it temporarily, but usually by the next day it's back to not working again. This is based on one of the examples you gave me, I think it was your office light rule if I'm not mistaken (I had to go back to march of Last year to find the message thread about it). I actually had simplified it since then and gone to straight motion activation .

Another alternative i use for certain rule cases is event engine.

This one turns in basement lights based on the door and motion combined and keeps.light long as there is motion.

1 Like