[Alpha] Community-maintained Google Home integration

Checked the scope and fulfillment URL and it's fine. Sent you screenshots of everything. Also, here's the log along with screenshot:

app:1042021-08-27 08:37:51.095 am debug{"requestId":"17567129171568400293","payload":{"devices":[{"id":"104","type":"action.devices.types.FAN","traits":[],"name":{"defaultNames":["Leviton 4-speed Fan Controller ZW4SF"],"name":"Living Room Fan"},"willReportState":false,"attributes":{},"roomHint":"All"},{"id":"74","type":"action.devices.types.FAN","traits":[],"name":{"defaultNames":["Leviton 4-speed Fan Controller ZW4SF"],"name":"Master Bedroom Fan"},"willReportState":false,"attributes":{},"roomHint":"All"},{"id":"139","type":"action.devices.types.FAN","traits":[],"name":{"defaultNames":["Leviton 4-speed Fan Controller ZW4SF"],"name":"Elijah's Bedroom Fan"},"willReportState":false,"attributes":{},"roomHint":"All"},{"id":"78","type":"action.devices.types.FAN","traits":[],"name":{"defaultNames":["Leviton 4-speed Fan Controller ZW4SF"],"name":"Back Porch Fan"},"willReportState":false,"attributes":{},"roomHint":"All"}]}}

app:1042021-08-27 08:37:51.062 am debug{"inputs":[{"intent":"action.devices.SYNC"}],"requestId":"17567129171568400293"}

--- Live Log Started, waiting for events ---

You are right, I still had the original Hubitat Google Home running (with noting in it). I deleted that app now.

Sorry for your trouble and thank-you for your response.

I'm looking into a problem with Google Home, because I can't relink Hubitat to Google Home anymore. I've have messaged Google back and forth with no answers yet. I always get the message "There are no devices in your Hubitat account".

Yannick

It doesn't look like you've given your fan device type any traits. Traits are what tell Google how to interact with your devices, so every device type must have at least one trait configured.

That means you either haven't configured any devices in the Hubitat app, didn't select any devices when linking to Google Home, or something's misconfigured in one of your device types or traits. The first two should be easy to rule out (just set up one or more devices and try again). If you have devices configured and selected, try turning on debug logging in the Hubitat app and posting any log messages that are generated when you try to link.

I have 76 devices configured in Google Home Community. They all have worked for the past year and a half. When I go in the Google Home app and add Hubitat I get the usual login from Hubitat, then I chose my Hubitat Hub, then I see a list of all of my devices and I can select each one with the click box or chose Authorize ALL or Deny. Then, after a few seconds, I get the message that there are no devices in my Hubitat Account (funny, it just gave me the list of devices ! ).

1 Like

Any luck on the remote control channel trait?

This trait works out great for a vertical blind project I just finished. I can use open/close, on/off, and brightness traits to control the blinds as usual. And then with the rotation trait I can control the rotation percentage also(*voice control only). works out great!

1 Like

Then definitely grab the debug logs while you do a sync and post them here. Sounds like it's just a misconfigured device type/trait causing problems with Google.

Greetings,

I've had the GHC app setup on my C7 for a while now, providing a means to cast my Unifi cameras to my Nest Hubs (by way of an RTSP to HLS docker image). This was all working great earlier this year, but now I can't seem to get any of my hubs to display either camera. When asking the hubs to "show me the XX cam", I get a "Sorry, it looks like the stream is currently unavailable from the XX camera". Similar message if I tap on the camera in the Home Control tab.

What's odd is that my HE logs aren't showing any errors for that app, and when I tcpdump from the AP that my hub is connected to, I never see an attempt to initiate a connection with my local HLS source. I can't remember exactly, but I thought the HE logs for the GHC app showed the stream URL that the virtual camera is set to when the cast request comes in?

Here's some logs:

app:1163 2021-09-01 02:12:20.285 pm debug{"requestId":"217049201389073811","payload":{"devices":[{"id":"1112","type":"action.devices.types.CAMERA","traits":["action.devices.traits.CameraStream"],"name":{"defaultNames":["Front Door Camera"],"name":"Front Door Camera"},"willReportState":false,"attributes":{"cameraStreamSupportedProtocols":["hls"],"cameraStreamNeedAuthToken":false,"cameraStreamNeedDrmEncryption":false},"roomHint":"Porch"},{"id":"1113","type":"action.devices.types.CAMERA","traits":["action.devices.traits.CameraStream"],"name":{"defaultNames":["Porch Camera"],"name":"Porch Camera"},"willReportState":false,"attributes":{"cameraStreamSupportedProtocols":["hls"],"cameraStreamNeedAuthToken":false,"cameraStreamNeedDrmEncryption":false},"roomHint":"Porch"}]}}
app:1163 2021-09-01 02:12:20.245 pm debug{"inputs":[{"intent":"action.devices.SYNC"}],"requestId":"217049201389073811"}
app:1163 2021-09-01 02:07:31.888 pm debug{"requestId":"14053847018838119864","payload":{"commands":[{"status":"SUCCESS","ids":["1112"],"states":{"online":true}}]}}
app:1163 2021-09-01 02:07:31.885 pm debugAll devices reached expected state and are ready.
app:1163 2021-09-01 02:07:31.883 pm debugPolling device attributes for 1000 ms
app:1163 2021-09-01 02:07:31.876 pm debug{"inputs":[{"context":{"locale_country":"US","locale_language":"en"},"intent":"action.devices.EXECUTE","payload":{"commands":[{"devices":[{"id":"1112"}],"execution":[{"command":"action.devices.commands.GetCameraStream","params":{"StreamToChromecast":true,"SupportedStreamProtocols":["progressive_mp4","hls","dash","smooth_stream"]}}]}]}}],"requestId":"14053847018838119864"}
app:1163 2021-09-01 02:06:58.939 pm debug{"requestId":"7250716365269299817","payload":{"commands":[{"status":"SUCCESS","ids":["1112"],"states":{"online":true}}]}}
app:1163 2021-09-01 02:06:58.935 pm debugAll devices reached expected state and are ready.
app:1163 2021-09-01 02:06:58.928 pm debugPolling device attributes for 1000 ms
app:1163 2021-09-01 02:06:58.887 pm debug{"inputs":[{"context":{"locale_country":"US","locale_language":"en"},"intent":"action.devices.EXECUTE","payload":{"commands":[{"devices":[{"id":"1112"}],"execution":[{"command":"action.devices.commands.GetCameraStream","params":{"StreamToChromecast":true,"SupportedStreamProtocols":["progressive_mp4","hls","dash","smooth_stream"]}}]}]}}],"requestId":"7250716365269299817"}

Has anyone had a similar experience recently? I want to say the last time I used this was in March, and possibly before my hubs had Fuchsia OS on them.

Apparently Google changed the camera API a while ago. @lpakula has had a pull request open to fix it for a while and I've just been lazy and forgetful and neglected to review and merge it. In its current state it will require you to reconfigure your CameraStream traits, but I'll see if we can make it backwards-compatible before I merge it. When I merge it I'll post here and make it clear if you'll be required to re-configure your devices.

1 Like

Let me check and make sure it aligns with your current trunk. I can make the changes.

1 Like

@mbudnek is this integration 2 way? So could I get a google home device into hubitat? Also does it work with media controllers?

It's only one way... You expose devices to google not google devices to HE. If the media controller supports chromecast in theory it should work

Is there a way to get Google Home devices into hubitat?

You could probably do it with an rpi and node red

Another developer "dkilgore90" has created "Google SDM API" that allows you to map in your Google devices with Hubitat.

I can see my cameras as well as bi-directional thermostat control. Currently I don't use Google for anything, except as a UI for voice/touch controls. I funnel everything through Hubitat for automations.

1 Like

Unfortunately that won't work because the devices in Google Home I want to bring into hubitat are not covered by SDM

I'm getting an odd error and I'm not sure where to turn. Background: I had half my Hubitat devices on the OEM Google Home integration and the other half on GHC... it's been relatively stable and working for months like that. I decided to move 100% to GHC so I moved all my devices over and fully uninstalled the OEM integration.

I could swear my GHC integration worked flawlessly on the first 2 tries then, and now continually, all my voice commands still work but I also get a voice error response to the effect of,

Sorry I couldn't reach the Hubitat and Hubitat 944 GHC Integration

How can I figure out what's going on? Super weird that my commands are all working but also giving a delayed error, no? I recognize one or two of the tokens in that audible response are my app/integration names.

Thank you very much for this apps! It works after a few trial and error when configuring a thermostat.
Is it possible to use a different number format when using celcius? I configured my thermostats to use celcius as a temperature unit, but in google home, I see an integer instead of a float. My thermostat is precise to 1 decimal number, can you adjust it? I've added the apps through the Hubitat Package manager so I should get a notification when done.

Again, this works very well and I can't thank you enough for this apps @mbudnek

Hmm, if your device reports its temperature in Celsius this app passes it on to Google without doing any rounding or anything. If you turn on debug logging and watch the log while you ask Google about the current temperature, is the temperature in the message that gets logged rounded off?

Hi,

I just received my Hubitat today and proceeded to play around with it. I was able to add a device (Window 1) and assign it to a room. I also linked Hubitat to my Google Home account and for some reason it displays 4 devices. I get that the phone is counted as 1 device, but perhaps the other 2 are Windows 2 and 3, also Zigbee devices, but currently still with SmartThings and works with GH just fine. I wanted to test out one device before fully transitioning the other 2 Windows. And also because Smarthings things for some reason pairs with the device, but is unable to control it. It's constatnly grayed out with network or system errors message and thus GH is unable to access it. Hubitat finds the device and works on the Hubitat without issues. However, Google Home is unable to present me the option to see the Window 1 or any of the 4 devices and assign them a room when linked. I did not create any rules, I just need Google to have access to it for opening and closing purposes. any help would be appreciated. It's frustrating when I am so close to getting it to work. Thanks in advance,




Is this supposed to be empty?

Download the Hubitat app