Alexa group not turning on


First week on HE, having problems controlling a room with Alexa.

I have renamed all my devices in HE in case of conflicts with room names e.g. lounge has devices called LNG_Light, LNG_Plug etc (mix of Hue and Z-Wave devices), I then have a HE group called GRP_Lounge with contains LNG_Light and LNG_Plug.

I then publish LNG_Lounge to Alexa via the Alexa Skill and place it in an Alexa group called Lounge.

When I say Alexa turn off Lounge it works fine every time, but Alexa turn on lounge fails every time.

If I hit the switch icon in the Alexa group it turns on and off fine every time also.

Any ideas why this could be?

Can you describe what "fails" means in this context? What response do you get?

Alexa comes back with bleep confirmation sound as if the command worked with a couple of seconds like it had not problem with the command, but nothing happens.

Weirdly if I call the group something else, e.g. "living Room" it works fine on and off every time, then changing it back to being called Lounge, it fails to turn on again but turns off fine!

I have a very similar problem with the words lounge and computer, join the club

Take a look at the voice command history on Alexa and see what it thought heard. There seem to be several words/phrases that Alexa misinterprets.

Alexa hears me correctly "turn on lounge" in history.

I was coming to the conclusion I just had to live with a name change on lounge, but have just run into the same issue with my Front Room, If I call that "Front Room" it fails in the same way, rename it to basement and it works!!!

Can't help but this is some historical thing that needs resetting to forget all history of groups or rooms.

OK mystery solved.

I had a routine that was responding to "Alexa, turn on lounge" with no actions :joy:

Hopefully, this helps someone else, though pretty dumb mistake on my part.

Thanks all


Just my 2 cents. If you use an Alexa routine with a specific phrase that Alexa can recognize, things work a lot better.