Aeotech Siren Driver Deprecated

Can anyone tell me why the Aeotech siren 6 driver is deprecated? and is this going to stop working at some future firmware update? I've been using this siren for multiple things including an alarm siren. I'd really hate to lose its capabilities.

[Aeotech Siren
(Aeotec Siren 6)
[Aeotec Siren 6 - Chime
(Aeotec Siren 6 Component Chime)
Aeotec Siren 6 Component Chime Deprecated
System

It was replaced with a new version.

No..

1 Like

If it was replaced with a new version how do I update it on mine?

If you're using built-in drivers, they're generally updated with the hub firmware. Have you upgraded the hub to version 2.2.5 yet?

edit: wait are you referring to changes made to aeotec drivers in the 2.2.4 update from a couple months ago?

I figured it out. Now I need to sort out some other issues.

The new version looks lovely in all respects... except one thing missing that I have been relying on, which is the number of repeats for the sound. I have the "chimes" sound going twice which is just long enough to wake me up and not so long it annoys the neighbors. If it only can play once through, it might not do the job. Any chance of adding repeats as a field along with volume, tone, and light effect?

3 Likes

And maybe at the same time fix the ongoing problem with the light effect selection not working.

And the Component Chime is also missing from the new driver. Wish Hubitat would bring back the deprecated driver as the "new" driver broke several of my apps.

Is there a way to force the light to stay on until an instruction turns it off? Ie to use the light as a light?

Did anyone ever figure this out? I used the component chime driver the same way @Inge_Jones described above, and now it just repeats indefinitely despite me sending stop commands at 2 seconds, 3 seconds, 4 seconds, 5 seconds and 10 seconds after start. This particular driver got worse with the 2.2.5 upgrade in my opinion. I used to know when one of my exterior doors opened, now I can't use this feature because it never stops.

The stop and off commands via the driver UI don't seem to work either

Luckily it does respond to a manual stop command, or I would have smashed my siren by now. But it's useless to me in its current form. Very disappointing. At least they got their queuing problem (or whatever it was dubbed) ironed out in 2.2.4, Hubitat as a whole was useless to me before that. Now it's just this one device. :confused:

Does anyone know of a good siren/door chime that isn't DIY? I'll go that route if I have to, but I'd prefer to just order something.

I was thinking of retiring mine and just getting another simple Neo Coolcam Siren. It only does one noise, that of a siren. But it does stop as soon as you tell it to!

This article contains some info on wiring a wireless chime from Amazon directly to a Konnected security system panel and using that in Hubitat. I just moved into a place that already has door and window sensors throughout the house, so I may do something very much like what they've done here.

The new version completely caused the Aeotsc Indoor Siren 6 to be completely non-functional except consume electricity.. Neither the chimes nor siren functions work, only the strobe light.. I excluded the unit, did a factory reset, reincluded the unit using the Smart Inclusion and WA-LA absolutely a total waste now.. lost full functionality, even tried changing the driver to component-chimes..

Tagging @bobbyD.

2 Likes

Can you try regular inclusion without encryption? We have not seen any incidents with the new driver. If your issues persist, please send me a PM with screenshots of your driver and we will try to sort it out.

2 Likes

Just FYI, mine continues to work fine with no obvious issues. I didn't change anything on it for months so wasn't even aware of a change. Its the siren with the chime too, not sure if that makes a difference.

Excluded, another factory reset, included without s2 and still no longer works.. worked on c5 and after the migration to c7.. only after exclusion and inclusion using s2 did the unit stop working.. no sound whatsoever, will not strobe only slow pulse to which I can turn on/off in the device menu.. the unit will not even make a sound anymore using the push button switch on the back of the unit.. coincidence.? Noticed that the driver was depreciated I switched to the hubitat supplied driver labeled as (NEW), noticed that the child device (CHIMES) disappeared but another primary driver labeled as chimes was available.. How can 1 physical device have 2 separate drivers?

Download the Hubitat app