Aeotech Nano Dimmer


#1

Just wanted to check if anyone has these devices dimming anything? I've installed and tried a number of devices and while I can get them to switch on and off no problems I don't seem to be able to dim. Was wondering if it's a problem with my light fitting or whether it's a problem with the fact that there is no proper driver for it.

Cheers

G


#2

HI,

I don't have a nano dimmer but I noticed they offer a dummy load.

From Amazon:

Aeotec Bypass for Nano Dimmer, Load Resistor and Dummy Load for dimmer, TRIAC dimmer switches to fix light flickering issue

The only reason I can surmise for such a load being required would be to help a non LED friendly device work with LED lamps. I could be wrong but for a quick test I suggest you try with an incandescent bulb if you haven't already.


#3

Already tried the dummy load and it made no difference.

Lamp "works" but doesn't dim. It's a straight on/off regardless of what I set the dimmer setting to. If I use one of the energy measuring devices I can even pull energy readings off the dimmer but obviously that isn't built into any of the dimmer controls I found. Manual switch also works fine.

As broadly speaking in the UK we use 2 wire lighting and the nano dimmer only provides dimming for resistive loads for 2 wire I wondered if the fitting was capacitive or something. It's supposed to support both training and leading edge dimming so I don't think it's that. Thought I'd ask the community to see if anyone else had got dimming to work through Hubitat.

G


#4

Yes I have an older house with no neutral in the light switches, so the Nano is one of the only devices that works. They dim just fine for me. I use the Aeon Micro Dimmer driver, which as you indicate does not show the energy usage, but seems to work ok otherwise. We can hope that one day there will be a driver for the Nano range of switches and dimmers with energy monitoring features exposed.

I would take a look at how all the option parameters are set. You can do this using the basic z-wave tool.

I was able to update the firmware in my three Nanos to v2.02, but they dimmed just fine before that also.

HTH


#5

Thanks.

I've tried using the Basic ZWave tool and I get nothing from it. I suspect I'm doing something wrong though. I'll keep playing.

Obviously it's working as a dimmer though so it's obviously the lights which is incredibly annoying.

G


#6

OK got the Basic Zwave device to work and changed some values but no luck. So I pulled the light fitting down and took a photo of the transformer. It's got the following details

Input 220-240v
50Hz Output 500mA
DC 20-24v
POUT 10-12W
Ta: 45C
Tc:85C
lambda > 0.9

At the top it also states Leading/Trailing Edge so I assume it's compatible with either approach.

I've dropped a message to Aeotec support as I'm assuming it's an incompatibility between the two. If anyone has any bright ideas in the mean time I'd be happy to give anything a go.

Thanks

G


#7

When you switch drivers, you have to hit Configure to pass the configuration from HE to the device.

Also, when you say "it won't dim" where exactly are you trying to set the level of the dimmer? From within HE or the external switch?


#8

In the Basic ZWave Tool I don't think I have to press configure (or maybe I do) as when watching the logs the dimmer tells me immediately that the value has been set and gives me feedback to that effect. If I then query that parameter it's set to the right parameter. Are you saying I STILL need to hit configure?

I'm setting it through either/both the Basic Zwave Tool and the Aeotec Micro Dimmer device in Hubitat. @jon1 above says that works fine on his neno so no reason to think mine should be different. On mine though it's showing classic signs of a dimmer/transformer mismatch as if I set it to 1% it turns off and set it to 2% and it turns on full brightness. Just can't work out why it's doing that right now.

G


#9

Are your bulbs meant to be dimmable though? LED bulbs are notorious for dimming compatibility with various dimmers out there.


#10

Hi,

Yes I thought the same originally but I took the fitment down and took a photo yesterday to make sure. As you can see it's fully dimmable and seems to support both leading and trailing edge. I have 2 of them up off the same switch but it makes no difference if I disconnect one or the other. I have a nano bypass in as well just to make sure but it makes absolutely no difference whether it's there or not I get the exact same issue/result.

Sorry I should say.

The bulbs are non-changable and integrated into the light fitting of which this is the driver for. So the driver is to drive the bulbs the manufacturer hardwired into the fitting which was the question you asked!

All very perplexing.

G


#11

I think I read somewhere that the Nano detects the type of load when it is first powered up, ie from the breaker. You'll see it go though a short sequence of fading the light on and off as it detects the load profile. There is a parameter that shows, and can be set, for the type of load, ie LED, incandescent, CFL etc. Mine are driving dimmable LED bulbs in regular fixtures.


#12

You correct however in a 2 wire config you can only have a resistive load and it can't be set (according to the manual) once it's detected, the parameter is read only.

I've done a bit of research on that and from what I can see any modern LED light is a resistive load anyway so not sure that would help even if I could change it. Then again I'm not ruling out I guess!

Thanks again for the suggestions.

G


#13

It's possible your LED is dimming by changing the frequency and your Nano is dimming by changing the peak to peak voltage.
Were you able to dim this LED before installing the Nano dimmer?
To isolate your problem. Try on another fixture with another type of light.


#14

Maybe.

They were brand new lights and the fixtures before had some Hue bulbs in there so dimming was never an issue. I also don't have a dimmer switch just a simple 2 way toggle as I never needed manual dimming control. I can use this as a last resort.

HMMMMMMMMMMMMMMMMMMMMMMMM

You've just made me think actually. I can't remember re-setting the nano after I changed the lights from the old Hue pendulum lights to the new lights. I will go and reset the nano completely and re-join it to the Hubitat and see if that solves the problem. Kinda hoping it's as simple as that but I'm not hopeful.

Thanks

G


#15

OK I've done an exclude, 20 second reset and re-add and it's exactly the same. Was worth a try but I wasn't expecting anything really.

I guess all I can do is wait for Aeotec to get back to me or go and buy a manual dimmer switch and see if that works.

G


#16

I was hoping you would put in another light fixture with dimmable light bulb to isolate the problem.


#17

Unfortunately I don't have one. Even if I did it's non-trivial to just change the lights and I am not at all convinced that the lights are "faulty". In fact I'm pretty certain neither are they're just incompatible which on reading is very common with LED's. I just assumed the situation these days was better and that I wouldn't have an issue.

Was holding out so vain hope someone had some magic wand to wave really :confused:

Thanks again

G


#18

Here's a parameter you can try and read from your load. I don't think your LED fixture is resistive.


#19

OK. Here's the response I got from Aeotec

Hi,

The issue as to why it won't dim is because Nano Dimmer does not support dimming for VDC loads, it can only turn it on or off.

Nano Dimmer technical specifications.

Please see the supported load section for Nano Dimmer. VDC options only have ON/OFF control only.

So bottom line is it's never going to dim only turn on and off. Not sure how you work that out from the info I have as I'm not even 100% sure what it means.

Now I need to figure out if theres any ZWave dimmers that support VDC loads. Anyone got any ideas?

Thanks

G


#20

That's a pretty bad answer from Aeotec. Your load input is AC 220-240 from the picture posted above.