Advanced Button Controller (ABC)

I did but I’m not at home and want to test it before posting. One of the small drawbacks of local system :). It should be up in an hour or two and I’ll update this thread when it’s ready.

1 Like

See if your router has a VPN option. My Asus does and it has been a savior on many occasions especially when I forget a work file while traveling!

Not yet…I have an Eero and this has been on their feature request list from day 1.
I also don’t plan to open outside access to my home network till I can do my research and do it safely and securely. If this hub becomes my primary HA solution I might have to escalate that research :slight_smile:

I tested the new parent/child apps and it works but found that there is at least one difference with how this hub initially creates the parent app. While it’s far from a deal breaker, I reached out to @bravenel to see if this is by design or if there is some tweeking needed.

App updated with parent/child format. Please let me know if you find any bugs

1 Like

So far it’s working for me! SMS’s notifications work, they didn’t with the built in controller app.

3 Likes

So far so good, thanks! One issue which is unrelated to your code is one of my v1 minimotes works fine for a day and then no longer works. I never upgraded the firmware on this remote. Have you had any similar issues? This remote worked fine for years on ST.

1 Like

I have my minimotes packed away in a box somewhere. They were replaced with Picos and actionTile tablets.

I’ll dig one out and test it. I’m pretty sure I upgraded the firmware on these when I first got them so I would recommend you do that as a test as well.

Thanks for the feedback. I just updated one of the remotes and will try it over the next few days to figure out if its firmware related.

I have the V1 with the new firmware and it’s working but you have to press the button a couple of times to wake it up after a long idle.

Unfortunately my upgraded minimote doesn’t work this morning. :disappointed_relieved:.

@JDRoberts, since the minimotes can be a second Zwave controller, do they have to be directly connected to hub versus connecting through Zwave repeaters? I have a U shaped home and my hub is dead center under the front stairs and my bedroom is on the same floor at the end of the U. I have many GE switches between the hub and the minimote that support the mesh. This remote worked fine in ST. Only difference is not every device has been moved to Hubitat yet, but again everything between the hub and my bedroom has.

Nope. They actually fall into a different device class, “portable controller” – – they know they may be physically moved around the network. So as long as it can reach any repeater on the network, it should be OK. :sunglasses:

2 Likes

Try using the short USB cable that came with the remote for upgrade. I could be wrong but I remember I was having a hard time upgrading with other cable before.

@ritchierich I installed one of my v1 minimotes a couple days ago. It’s still working today. I’ll report back this weekend if it disconnects between now and then.

Thanks. Unfortunately I have given up using them and resorted to my iPad. Issue could be a mesh issue though I have 17 devices Zwave switches between the hub and the remote. Until Hubitat engineering fixes the logging of physical events for GE switches I won’t be migrating any other devices from ST.

Keep in mind that the problem with these types of switches/dimmers is that they are incapable of reporting state changes on their own, ST got around this by implementing some very aggressive background device polling, the net effect of this being that all zwave devices irrespective of their capability to report state changes of their own volition, are queried for state reports.
We felt implementing this type of heavy handed approach to support less capable device hardware wasn’t in the best interests of performance, so we’re discussing less intrusive, device targeted options right now,

3 Likes

I posted this (old history) in another thread; it doesn’t sound like aggressive polling is necessary. Rather, the hub issues a refresh to a targeted device. May not be perfect, but it seems to work well enough :

Delayed actions... need help - developers - SmartThings Community

1 Like

So the real story is not that these switches/dimmers are incapable of reporting state changes, it’s that their manufacturer’s opted not to pay Lutron’s licensing fee for "sending the status of a radio controlled switch when someone physically actuates the device, which very likely kept costs down, resulting in a more competitive price, and a lot of people buying them, not realizing this lack of a key feature. I certainly didn’t. I’ll have to look at the manuals to see if GE specifically points it out.

I honestly hate “obvious” patents like this one. There really should be a royalty cap on obvious patents, and an expiration date as well.

Stephack, I’m looking for a way to setup the normal dim up/down buttons on a lutron caseta nano to cycle up/down the effects on a Nanoleaf.

Currently the command on the nanoleaf integrated api just uses a “setEffect” and a number, and the number corresponds to an effect in the following list, for my own Nanoleaf… and this list changes depending on which effects are added/deleted.

Can you add an option for “custom command” as a button press? Or is it in there somewhere already? Below is my effects list as generated by

### State Variables

* effects :  **[{0={name=Christmas Lights}}, {1={name=Color Burst}}, {2={name=Fireworks}}, {3={name=Flames}}, {4={name=Forest}}, 
{5={name=Inner Peace}}, {6={name=Meteor Shower}}, {7={name=Nemo}}, {8={name=Northern Lights}}, {9={name=Paint Splatter}}, 
{10={name=Pulse Pop Beats}}, {11={name=Rhythmic Northern Lights}}, {12={name=Ripple}}, {13={name=Romantic}}, {14={name=Snowfall}}, 
{15={name=Sound Bar}}, {16={name=Streaking Notes}}, {17={name=Vibrant Sunrise}}, {18={name=Warm White}}]**