Adjusting sensitivity for SmartThings Multipurpose Sensor V5


#1

I have a rule set up to trigger when a SmartThings Multipurpose Sensor V5 sensor is "active" (accelerometer is in motion).

My problem is that it is overly sensitive and I would like to set some sort of threshold (either based on amount of motion or time in motion).

Is there a way to do this with the rule engine and/or could I write a custom app or driver to accomplish this?


#2

I think you'd only be able to do that with a custom driver. I didn't see anywhere in RM where you can test for amount of motion or time in motion. :frowning:

@bravenel might be able to elaborate on that.


#3

Might "possibly" be able to accomplish this with the WATO app using the devices attributes, but not sure. [RELEASE] WATO - When any Attribute Then this cmd Otherwise that cmd Otherwise it's probably specific driver related that needs written


#4

My v5 sensors seem to 'sleep' pretty heavily. The older models would respond to slight vibrations and were perfect for chairs, washer/dryer, door knocks, etc. I set up a little app before where I could spin a multi in a circle like a knob. I think ST even made a promo video with just that use-case.

V5, does not report active/xyz until you slam it pretty hard, then it will feed real-time data with great accuracy. Once it goes back to sleep, it takes another heavy slam to wake it up. I have one on the back of my computer chair, and I have to actually punch the chair to wake it up, then it detects me moving around. I'm not sure why it's so much less responsive than the old ones, other than perhaps they were trying to improve battery life. Not a trade-off I would want to make myself.