Adding Graber Somfy Shade & Remote to Hub

Hi all,

New to Hubitat, contemplating moving from Smartthings.

At this point just testing to see if a migration will work for me. GE switches and dimmers work fine so no issues there.

The next crucial device types are the Graber/Somfy shades. These worked fine on ST though they had to be turned on and off instead of opened and closed. On ST they also required the remotes be added.

I've searched high and low here for an answer, as well as the general Internet, but can't figure out how to add the remotes. I need the remotes because the high and low defaults for the shades get lost somehow and Hubitat will only move the shades between about 20% and 25% open. That's obviously not usable and there appears no way to adjust the defaults within Hubitat.

Any suggestions? There must be something painfully simple that I'm just not picking up on. I have to think others have managed this given the amount of discussion on other issues with Graber/Somfy.

Thanks in advance,

Al

It’s been a while since I moved my Graber shades (and everything else) from SmartThings to HE.

But as far as I can recall, I used the same set of steps that’s in the zebrablinds YT videos for ST when pairing the shades and remotes with Hubitat.

Thanks for the quick response. I went back and watched that video, but Hubitat never sees the remotes, hence my dead end.

so you're unable to pair the remote to hubitat?

Correct. The shade will pair, but then as a separate inclusion process the hub never detects the remote.

Are you certain the remote was successfully excluded?

Anytime I'm having trouble pairing a new (or used) z-wave device, it never hurts to put the hub into general exclusion mode and then perform the device's stated procedure for entering exclusion mode as well.

If you watch the hub's log while doing this, you'll see a confirmation that an unknown device was excluded.

2 Likes

If I remember correctly. You won't know when the remote is added unless you have the log open when paring. Once pair. You will see an unknown device in the z-wave setting page. I think that was how a few of us got them to work. It's on the forum somewhere just too long back to find.

Yeah TBH I can't remember if I changed the driver to a Somfy remote manually or not.

But I didn't have that hard a time pairing my remotes, I have several.

1 Like

Found it. Posted by @DeveloperDavidB

I did get them to work, and right before the update. The new driver is nice to have, but isn't needed in order to get them to work with the blinds. Paired as a device works fine. Turns out the problem I was having was just that I didn't know there was a different method to pair secondary devices. These are the steps I did to get them to work with the blinds. The remotes are working perfectly for me now.

Pair to Hubitat

1- factory reset it, hold the program button with a paperclip until the remote is reset.

2- open a window with the zwave information page

3- open a separate window and start device discovery

4- hold down the program button on the controller until green flashes. (Around 3 seconds)

5- refresh the zwave information page until you see the device show up with the discover button in the right column

6- click the discover button,

7- Exit the device discovery page

8- Find the device in the Devices page, and rename to something meaningful.

Pair to Blinds

9- Quick tap the program button on the back of remote with a paperclip.

10- Hold down button on blinds for around 3 seconds until the green light flashes.

11- Blinds should jog to let you know they are paired.

1 Like

Worst case, use ST to set the high/low. Exclude the shade from ST instead of reset. Pair the shade to HE. This way the high/low will still be there.

1 Like

So the remote was still listed on ST. I force removed it and then reset everything a couple of times and was able to get both the shade and remote paired and I think working properly. I'll have to play some more before I'm 100% sure about everything, but seems it was what you suggested.

Thank you!

This is great, explains step by step what needs to happen.

Thanks

I have a new Graber Z-Wave shade and a Graber Premium remote control. The Premium remote has 12 channels and can can control up to 24 shades.

I was able to easily pair the shade with my Hubitat Elevation but have not been able to pair the Premium remote with the Hubitat even using the procedure outlined above.

Has anyone successfully paired a Premium remote with a Hubitat? Any thoughts or ideas on how to get the pairing to work would be greatly appreciated.

Thanks in advance for the help

I have never used that remote. I will be interested in what you learn!

Solved. Since the Premium remote has a small display you have many more options available to you. In fact there is an entire submenu of Z-Wave functions. I was trying to pair the remote with the HE using the same function I used to pair the remote directly with a shade Z-Wave->Include. This doesn't work to pair the remote with the HE. Instead you have to use Z-Wave->Learn. Once I did this the remote paired immediately with the HE using the process included above.

My thanks to Graber Tech Support for solving this.

1 Like

Download the Hubitat app