Add RGBW Z-wave Plus Bulb to Drivers

Could you please add this to a driver or create a driver. The bulb is an Ilumin LZW42. Here is the info it had when it was included. It is trying to use the Aeotec LED Bulb 6 Multi-Color driver. It is not acting right using this driver. You can turn it on and off on the device page but the status on the right side does not change. TIA

ID: 8C

Manufacturer: 031E

Product Name:

Model Number:

deviceTypeId: 111

nodeId : 8C

deviceId : 0001

manufacturer : 031E

deviceType : 0005

inClusters : 0x5E,0x85,0x59,0x86,0x72,0x5A,0x33,0x26,0x70,0x27,0x98,0x73,0x7A

outClusters :

@razorwing

Here it is

1 Like

@ericm I have downloaded the driver. Seems to work for on/off but you can't set the CT. I have done the ole configure several times with refresh and no change. I have also reset and re-included the bulbs a couple times but no change. I have 2 bulbs acting the same.

Could there be a change to these bulbs that is not known?

In the manual there are two parameters 81 & 82.

81 covers 2700-4999
82 covers 5000-6500

The driver only has cold and warm white. Would that have anything to do with it?

You can set the color by using the window but not by number. Also the color status reads all #000000 for all colors. Saturation status reads 0 even if you type in 100 and enter it.

Not sure.. That is the official driver from the manufacturer... Hit up their developer @ericm

OK, thanks. I will change the name from yours to his.

@ericm Eric, any chance you could take a look at why the driver for the color bulb is not allowing control of the bulb? Is there a firmware upgrade that may need to be applied? See the post above for more explanation. Thanks

Eric should answer here but if he doesn't by Monday you can also ask at https://community.inovelli.com/

@anon61068208 Yes it is a bad time of year so not a problem. I will wait and see if he responds in the next few days. It is not a big deal just trying to find some nice bulbs that are not so expensive. Thanks for the response. I will take a look at the forum.

1 Like

If I recall correctly, they are running behind on support requests. They had some staff turnover that's causing a backlog.

@razorwing, I will take a look at what is going on. As mentioned, we are a little back logged right now with the holidays, but I will try to get to it over the next couple of days.

@ericm No problem. I wasn't sure if you saw the other thread. Take your time, after all it is the holidays. Happy Holidays!

@ericm I've noticed that when setting up a scene in Hubitat I cannot set the color temperature for these bulbs. They default to a cool white whenever the scene is activated. When I manually adjust the scene properties there is no option to set the temperature. If you're able to look into this when you have a chance to delve into the driver, I'd appreciate it. If you need more info on this please let me know.

For anyone in this thread that hasn’t noticed.. I released fixed drivers for these bulbs.. I even have a pull request to get these changes into the official drivers...

Link to fixed drivers thread: