[2.3.4.114] Thermostat Schedular Eco mode

I was setting up Away mode in thermostats scheduler 2 or 3 days ago and nothing seemed to be functioning and did not have time to work on it before tonight, today I upgraded to the new 2.3.4 firmware but now when I select the "Use EcoMode when Away", it changes to the EcoMode on all the time, either present or away, it does not seem to work.

Unless I'm just not understanding what "Use EcoMode for Away" means, I was under the impression that when everyone leaves and the hub mode turns to Away, EcoMode turns on and all thermostats drop from the number of degrees programmed (or goes up in cooling mode).

Right. Please show a screenshot of what you are seeing in the app set up.

Evening mode and Away mode both have the exact same screens. If I click on the "Use EcoMode for Away" it changes to Away Settings (wich are not set) and EcoMode Turns off right away.


Without using the EcoMode when Away setting:


OK, I see the problem. We will get this sorted out for the next release.

2 Likes

I had this problem too and it was corrected in the latest release, BUT now it won't switch with modes. If I switch the mode with mode manager to Away, everything works as expected with eco-mode. And when I turn the mode manager to Afternoon (for example), it takes eco-mode off as expected, but the "Afternoon" (or any other mode) set points don't get applied until I manually click "Set Scheduled Temperatures".

ie. if the mode changes from morning to afternoon, the logs show the mode change, but the temp setpoints don't get changed. There's no logs for TS until I hit "Set Scheduled Temperatures"

Are you on 2.3.4.115?

yessir!

Yeah, there is still a problem with this. Fixes in next release.

1 Like

Thank you sir! Works properly now after latest update.

1 Like

In TS I am scheduling based on time periods. In Mode Manager I have several away modes. How does TS know which modes = Away for the purpose of using the away settings?

It only uses the mode called Away.

So if my away modes all have additional text they are not treated as away by TS, correct?
image

So I need to use Rule Machine to force away/Eco mode in TS then?

Thermostat Scheduler only treats the mode called "Away" as Away.

1 Like

Download the Hubitat app