2.3.3.121 / C-7 - Unable to Select Devices / Apps in Logs Screen

I tried using the new Device / App filter on the logs screen, but whenever I click one of the devices or apps, the drop-down disappears and the logs do not appear to be filtered. The same thing happens when I try clicking in the text box at the top, the drop-down disappears. I'm using Chrome on a Windows 10 PC if that is important.

The issue does not occur in FireFox.

Seems to work for me...Win 11/Chrome latest

Works if I select two items to filter on as well.

Yeah, I just tried it on my other hubs and it worked for them.

Wondering whether it is the larger number of devices / apps I had listed on my lighting C-7 hub in my original screenshots...? I tried closing Chrome and disabling the Dark Reader extension, neither of those had any impact...

My app/device list looks about as long as yours bit filtering still works for me.

I was checking on my hub that has 99% of my devices, so I don't think it's related to having "too many" devices.

I was thinking more the number of devices displayed at the top of the logs screen, not strictly the number present on the hub in total. That said, I tried resizing the browser window to try and replicate the issue by clicking in the list where there are devices displayed behind the drop-down and it still worked. Weird...

I don't think it's that (number of displayed devices/apps) - I have just over two full screens of devices/apps listed before the logs appear.

This is strange, if I click the X in the top right I can then select from the list:

LogsDeviceAppSelector

Apologies for the poor quality image....

Don't get me wrong, it's not a big deal, this is a new feature and happy to see it included, and it's not stopping me from doing anything or getting in the way of my existing use of the hub, don't want it to come across like I'm complaining, just wanting to report what I have seen.

I still can't replicate your issue on Chrome.

I did have a mysterious display issue recently that affected Rule Machine w/Chrome, and the only way I could find to resolve it was to clear bowsing data from Chrome. Specifically clearing Autofill Form Data and Site Settings seemed to do the trick. It may have been only one of them, but unfortunately I cleared them both at the same time so couldn't separate out which one was the key. Prior to that I had Cleared cache, cookies, etc., which didn't help (at least on their own).

You might try clearing some of your browsing data in Chrome and see if that helps.

Are there any devices with some rich HTML in their names? I'm talking more than span tags with color styling, something a little more advanced maybe?

The only two that stand out are HE scenes with the color styling for "Not Set". Apart from those, nothing that I can see at a glance...
But the list across the top of the screen does bounce around a little when I select some devices, so there must be something funny going on...

I tried clearing Cookies and Other Site Data, closing and re-opening Chrome and still saw the same issue. Same result for clearing aut-fill form data.

1 Like

Well...I'm at a loss, my tiny brain has used all its connector-thingys. :wink:

@gopher.ny - any ideas on this?

2 Likes

Download the Hubitat app