[2.3.0.112] delayedActs Error on RM 5.1

@bravenel
I have an hourly chime setup that used to work but doesn't work anymore in 2.3.0 even in beta now that I think of it. I've been so busy lately so finally getting around to checking it now.

Here's one of the rule:

Here's the logs showing an error when I have logging all enabled:

The chime sound itself never plays although it works fine if I do it manually on the device page for that siren so the issue doesn't appear to be the device itself. This is a Aeotec Siren 6 that I'm playing the chimes for, it plays a Cuckoo Clock sound. I have a separate rule for each hour since I have the delay timed to play the cuckoo sound the number of times to match the hour like a real cuckoo clock does.

I will investigate. We did find a bug with the Chime action, and this is probably related to that. If so, the fix will be in the next release.

1 Like

113 build didn't seem to fix this issue, I'm having the same error and the chime sound isn't working at all still in RM but works on Device page. I saw the updates mentioned using Chime with a variable, I'm not using a variable at all in this case.

Please remove this rule and re-create it. You can see from the error message that it's doing something with %now%. Did you used to have that in the rule somewhere?

No I never used variables at all or ever used %now%, the rule as pictured hasn't changed since RM 5.1 was first released. I'll try deleting one of these and recreating it and report back.

I did clone one of the rules to make the other 11 rules (1 for each hour) and just modified the delays, time and names but that was all done when RM 5.1 was first released and I deleted the RM 5.0 version back then too.

I think recreating the rules fixed it, not sure where the %now% came from. I updated it from 12 rules to 2 using a new variable for the delay and so far no issues.

In doing so, I noticed a minor GUI spacing glitch on the display if it's something you think should be fixed at some point:

It should have a space between the variable name and the delay time.

This is where I'm using the variable at:

Thanks. Yeah, that UI needs a little cleanup. The actual time from the variable should by hideable, and black text within black parens.

Like this:

That looks much better and the chimes are working perfectly now on the new rules I created.

@bravenel
While I'm already bringing up display GUI issues in RM, is a label missing on this one?

image

On the same page the TTS and Music Players buttons has a title on the button which I'm guessing maybe is missing on the Notification devices button:

Should it have a title on the top of the button that says:
"On these notifications devices"

I'm sorry. Please provide more context for where this is.

That section is under Actions located here:

Thanks, easy fix.

2 Likes

Download the Hubitat app