2.2.9 Scenes - New devices do not appear In Adjust Scene settings

I added a couple new Zigbee bulbs - they work fine. I added them to a scene - they appear in the Bulbs drop down. They do NOT appear in the list of devices in "Adjust Scene Settings" even after Update Scene or Done (and coming back). They still show up checked under Bulbs, but no way to "set" them in "Adjust..."

I found the same issue with a Lutron dimmer. I activated the scene and then re-captured it and the device appeared. Not sure if this is a bug or working as designed...? It's been a bit since I messed with scenes so I can't remember if this was introduced in 2.2.9 or not... what hub version are you on?


Yeah sure enough I down graded to and merely selecting it from the "select dimmers" dropdown adds it to the scene. In you have to select it from the "select dimmers" dropdown and then activate/re-capture the scene.

Sounds like it may be time to call Bugmaster Bobby... @bobbyD but since there's a pretty simple workaround probably not high on the critical list!

I modified the subject slightly to reflect the additional info.

Select additional device (office sconce right) from dropdown

Screen Shot 2021-10-10 at 11.57.43 AM

Click Update, device does not appear

Screen Shot 2021-10-10 at 11.57.53 AM

Click re-capture, device appears

Screen Shot 2021-10-10 at 11.58.00 AM

My bulbs don't show up in the dimmers group - only the bulbs group. Even after activating the group - I still cannot set the bulbs in the scene settings.

Right... but it also happens in the dimmer group so that's what I used for screen shots since my nonprod hub happened to have some dimmers but no bulbs. I didn't want to mess with a production hub.

It's always worked this way. You can only adjust devices that have been captured. When you add a device to an existing Scene, you must hit Re-capture to include it in the Scene. It will not show up in adjust Scene until you do this. The next release will make this more obvious by an in-app instruction to that effect.

I'll look into it. Not aware that any of this changed, but it's possible. In the meantime, Re-capture the Scene. Also, please show the entire Scene app setup in a screenshot.

Thanks. You can delete those images now to make this thread a bit cleaner. I am able to reproduce the issue. Will find the fix for next hot fix....

1 Like

This problem, with a new device not showing up, has been found and fixed. Threw part of the baby out with the bath water. Next release...


This problem fixed in new release:


Download the Hubitat app