[] Local Files in RM

What happens to the local files accessing in
It use to be [hub-ip]/local/fileName and worked up to
I am still using RM4.x
All my announcements are stored locally as MP3 files.
After upgrading to all announcements referring to the
local files are not working anymore.

Could show one of these rules, screenshot.


still works for me. So does access to /local/file-name in Rule-4.1.

Here is one of broken (in term of no announcement) rule (part of Button Controller):

Here is another one:

And there are few more stopped announcing but the rest is OK.
There is a Global Variable for defining files location:

There are few rules which do not use local files.
These are still working fine, so there is no problem with a speakers:

(Announcements are in Russian language).

My original intend was to use embedded messages.
It worked for few first rules but when I added more rules
announcements still worked but wrong messages was
announced. I guess, @mike.maxwell said it was due to
8-bit Russian characters.
So I have/had to use MP3 based announcements because
of this problem (maybe this already was fixed but I did not try).

Check those URLs by entering them in your browser -- that should download the file. Nothing has changed with this in Rule-4.1.

Your level of complexity is beyond my ability to troubleshoot.

5 posts were split to a new topic: Problem with Sonos Driver

I meant for the lock.

I understood, this was for the lock, not HE.
But factory resetting lock and then reconfiguring all its setting
back is not an easy task.

OK, if it won't join, it is probably not actually fully excluded.

2 posts were merged into an existing topic: August Lock broken communication

Local files working as expected. Other topics moved to appropriate topics, so this one is now closed.

1 Like