2.2.6 upgrade

So I recently came to use Hubitat from WINK. WINK support and their whole platform had issues over the past year which forced me to look for something better.

That said I tried to perform a code upgrade from 2.2.5 to 2.2.6 this past week...

Luckily I pulled all the backups prior to the upgrade.

I ended up having to restore the 2.2.5 version and soft reset utilizing a previous backup to get the system back on its feet. Its working again... but the following did not work

according to support but these did not work

  1. tried rebooting
  2. tried previous version 2.2.5
  3. tried safe mode and removing myQ chamberlain drivers and apps

So then after the soft reset and applying previous backup from 2.2.5 its up again...

I could not see logs which might indicate what failed on 2,2,6...

Is this kind of thing normal on this platform...?

Normal, no. Frequent after a major (2.2.x) upgrade, yes.

There are typically some people that have issues after every platform update. You will notice that there are often hot fixes after each as bugs are found so Hubitat is quick to react. Hubitat staff monitor this community and frequently jump into help.

It would be hard to use the term "normal" or "frequent" because all of the people who don't have problems don't post that everything went perfect. I just learned about "Survivorship Bias" somewhere else last week. Interesting concept and probably applies here. :grin:

EDIT: I forgot to add, Welcome to the Community! and sorry it got off to a bad start. There are plenty of people to get everything back on track. If the community can't help, i bet @bobbyD with Hubitat can.

3 Likes

Yep, this is the first upgrade which went badly for me. I had upgraded to 225 with out incident so it all looked promising.

This was the first upgrade with issues.

Any idea how to troubleshoot issues with upgrades to determine what is failing on a specific upgrade?

Logs do not seem to help as they were empty post upgrade and I could not see anything that would help in safe mode to determine the issue

Can you describe what led you to go back to 2.2.5? If it’s an issue that support knows about they may have a fix, or maybe someone here has a work around that may be acceptable.

2 Likes

I see a bunch of "The datetime zone id 'SystemV/EST5EDT' is not recognized" messages in the logs. It's unlikely it messed up 2.2.6 specifically, but I suspect it had something to do with the upgrade problems. It first occurred on 3/24.

2 Likes

Download the Hubitat app