[] Z-Wave Lockup during repair: Z-Wave Network responded with Busy message

I moved my hub today so was running repair to make sure that everything was able to communicate. During the last repair, I started getting the dreaded

Z-Wave Network responded with Busy message.


Z-Wave Repair results

Current experience:

  • Control of any zwave switch from hub/dashboards silently fails (no logs)
  • Z-Wave reports from motion and contact sensors and switches are being received and handled

@bcopeland I have captured the html from the zwaveInfo pages and json from zwaveNodeDetail in case they are helpful.

FWIW, I don't know what the official guidance on this is, but when I moved my hub about 30' and from one room to another months back, I just let the hub sit in the new location for a day or two w/out making any changes. The Z-Wave Plus devices are designed to re-route on their own if they don't have good connections, and Zigbee will reconnect (they go into "panic mode" when the hub is off for 20 minutes) so I wanted to give the devices/hub a chance to work things out on their own. It's been a while so don't remember exactly when, but I also did a full shut-down/reboot a little later "just in case." :slight_smile:

I never did any Z-Wave repairs and things kept working.

Did you have any issues w/devices not working/not reporting when you ran the repair, or just doing it proactively?

Do you have any devices on the Z-Wave Details page that are missing a name or routing info (last column)?

I am sure that eventually everything will self repair... eventually.. problem is in the mean time things are just broken. :frowning:

Good question. I had a few devices that were responding slowly, but mostly figured it couldn't hurt...

No ghosts. One device (0x34) which is offline (and showing FAILED in z-wave details, as expected), but otherwise all devices are OK.


For what its worth, a simple reboot seems to have recovered things.


I LOVE simple things (like me). :wink:

Hopefully the improvements will stick!

I had something similar happen. I moved two z wave devices from one hub to another hub as well as their physical location. I rebooted my hub and waited a few hours. When I tried to run repair, every z wave device was unresponsive. I rebooted waited an hour and tried again. Same thing. One more reboot and things started working again.

I am having similar issues myself. When I run a repair on random devices it will get all the way to assigning route #5 and then hangs from there. At this point all zwave becomes non-functional and the only way to recover is a power cycle.

Same here.
I think that they (that is the support people) should include a sequence in the upgrade procedure which would "turn off" the Zwave Radio (for the minimum length of time), since this seems to "fix" things for some people (me included).
They are smart people, I'm sure they can do it.
(Just a suggestion).
@bcopeland @gopher.ny