[2.2.3.135] Zwave command VersionGet not working. [C7]

I'm not sure where in the beta's this may have stopped working but I was writing a new driver and noticed that versionGet isn't working anymore in any of my drivers.

I then loaded the basic z-wave tool which was recently updated by @mike.maxwell and it the versionGet does not respond there either. It did at one point because my driver has the variable set for the version when I initially ran it. Actually, getAssociationReport,getVersionReport an getCommandClassReport don't work in the basic z-wave tool anymore. I tried it on an old device that I used it on before as well as a test and the devices aren't responding with the info. However the getParameterReport does work. I've used this tool when creating a lot of my drivers so I know it did work at some point.

Was anything changed that could have broken these methods in 2.2.3?

1 Like

I've never gotten the version report to work on non-S2 devices on my C-7. Even worse, at one point Iam sure requesting multiple version reports locked up my zwave (although that was on the very 1st release - not sure it would do that today).

I admit I only tried a few times, though before I moved on to other things.

1 Like

Really?.. I thought we had fixed that.. Ok.. Putting that back on the list

Hmm.. makes sense. All my devices are using no encryption on my C7. I only noticed it since I was working on another driver.

Thank you. Also I was having issues with the association group methods too. I'm not able to query the association groups for members. Might want to add that to the list as well.

1 Like

Oh this sounds all too familiar.. I think I have an idea where to look for the problem.

1 Like

No worries. You were busy with more important things, and I was afraid to try it too many times since my hub is working so nicely.

I have my development C-7 on the way though. That one I can break more freely lol.

Get Version worked fine with the basic z-wave tool prior to the most current release on a C4 hub. I reported this as a problem with the basic z-wave tool itself, here:

1 Like

Download the Hubitat app